Bug 188752 - slotchange event does not fire with initial content
Summary: slotchange event does not fire with initial content
Status: RESOLVED DUPLICATE of bug 169718
Alias: None
Product: WebKit
Classification: Unclassified
Component: DOM (show other bugs)
Version: Safari 11
Hardware: Macintosh macOS 10.13
: P2 Normal
Assignee: Nobody
URL:
Keywords: InRadar
Depends on:
Blocks: 148695
  Show dependency treegraph
 
Reported: 2018-08-20 11:44 PDT by Jan Miksovsky
Modified: 2018-08-27 21:22 PDT (History)
3 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jan Miksovsky 2018-08-20 11:44:48 PDT
See http://jsbin.com/wirubeq/edit?html,console,output.

In Chrome/Firefox, when a component with light DOM content is attached to the document, and a slot is created with a slotchange listener, the slot will raise an initial slotchange event. Safari does not do this.

The Chrome/Firefox behavior is useful because it allows a component to concentrate its initial content processing in a slotchange handler. To get consistent behavior, we have to normalize the slotchange behavior across browsers, which is cumbersome.
Comment 1 Radar WebKit Bug Importer 2018-08-20 21:11:29 PDT
<rdar://problem/43544149>
Comment 2 Ryosuke Niwa 2018-08-27 21:22:28 PDT
This is a duplicate of webkit.org/b/169718.

*** This bug has been marked as a duplicate of bug 169718 ***