Bug 18820 - WebKit misplaces caret when scrolling text areas via page-up/page-down on windows
Summary: WebKit misplaces caret when scrolling text areas via page-up/page-down on win...
Status: RESOLVED DUPLICATE of bug 18819
Alias: None
Product: WebKit
Classification: Unclassified
Component: Forms (show other bugs)
Version: 528+ (Nightly build)
Hardware: PC Windows XP
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-04-30 17:53 PDT by Eric Seidel (no email)
Modified: 2010-03-04 20:45 PST (History)
3 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Eric Seidel (no email) 2008-04-30 17:53:12 PDT
WebKit misplaces caret when scrolling text areas via page-up/page-down on windows

1.  Type a bunch of text into a text area
2.  use page-up or page down to scroll the text area

Expected:
the text area will scroll, moving the caret, but the caret will be in the exact same position as it was, relative to the borders of the text area.  the text will simply scroll underneath it.  See Firefox on windows for an example.

The mac version of this bug (which is slightly different):
https://bugs.webkit.org/show_bug.cgi?id=18819
Comment 1 jaroslav.benc 2009-09-30 22:33:43 PDT
This is also a problem when document is in edit mode, caret doesn't move when page down/up is pressed as expected in most of the editors.
Comment 2 Tony Chang 2010-03-04 20:45:59 PST
I'm marking this as a duplicate because the fix for bug 18819 fixed this as well.

*** This bug has been marked as a duplicate of bug 18819 ***