Bug 187907 - [Meta] Ensure element queues are properly pushed/popped from custom element reactions stack
Summary: [Meta] Ensure element queues are properly pushed/popped from custom element r...
Status: RESOLVED DUPLICATE of bug 154907
Alias: None
Product: WebKit
Classification: Unclassified
Component: HTML DOM (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-07-23 08:50 PDT by Frédéric Wang (:fredw)
Modified: 2018-08-01 17:54 PDT (History)
3 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Frédéric Wang (:fredw) 2018-07-23 08:50:20 PDT
These are the places where such operations are mentioned in the spec:

1) create an element for a token
   https://html.spec.whatwg.org/#create-an-element-for-the-token
   This is at least making one test fail in custom-elements/parser/parser-sets-attributes-and-children.html and causing the ASSERT in bug 187802.

2) insert a foreign element
   https://html.spec.whatwg.org/#insert-a-foreign-element
   This is at least making another test fail custom-elements/parser/parser-sets-attributes-and-children.html.

3) Operations, attributes, setters, or deleters annotated with the [CEReactions] extended attribute
   https://html.spec.whatwg.org/#custom-element-reactions:custom-element-reactions-stack-5
   Hopefully, we already do all the necessary calls, but bug 187851 will make sure we don't miss anything.
Comment 1 Ryosuke Niwa 2018-07-31 19:34:42 PDT
We need to be very careful with respect to how this work affects perf.
Comment 2 Ryosuke Niwa 2018-08-01 17:54:12 PDT
We don't really need a meta bug like this separate from the bug 154907.

*** This bug has been marked as a duplicate of bug 154907 ***