Bug 187816 - iframes don't support wildcard operator according to spec
Summary: iframes don't support wildcard operator according to spec
Status: RESOLVED CONFIGURATION CHANGED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebRTC (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified iOS 11
: P2 Normal
Assignee: Nobody
URL:
Keywords: InRadar
Depends on:
Blocks: 183300
  Show dependency treegraph
 
Reported: 2018-07-19 13:03 PDT by Jeff Gardner
Modified: 2023-05-02 07:07 PDT (History)
5 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jeff Gardner 2018-07-19 13:03:26 PDT
Using the following specific allowlist to try and enable the microphone and video from all origins in Webkit doesn't work according to the spec outlined here: https://wicg.github.io/feature-policy/#allowlists

What we're using (that works in Chrome and Firefox): allow="microphone *; camera *; autoplay *;" 
What we expect: This should allow all origins within the iframe to request access to those permissions.
Comment 1 Radar WebKit Bug Importer 2018-07-20 19:34:48 PDT
<rdar://problem/42454725>
Comment 2 Daniel Bates 2018-07-20 20:13:40 PDT
We do not support feature policy at the time of writing.
Comment 3 Daniel Bates 2018-07-20 20:14:05 PDT

*** This bug has been marked as a duplicate of bug 183300 ***
Comment 4 Daniel Bates 2018-07-20 20:16:33 PDT
(In reply to Daniel Bates from comment #2)
> We do not support feature policy at the time of writing.

Disregard this remark.
Comment 5 Daniel Bates 2018-07-20 20:17:19 PDT
Re-opening bug.
Comment 6 youenn fablet 2023-05-02 07:07:17 PDT
'*' is allowed so this should work as expected.
Marking as Configuration Changed