Bug 187592 - Epiphany Technology Preview: error while loading shared libraries: libdw.so.1: cannot open shared object file
Summary: Epiphany Technology Preview: error while loading shared libraries: libdw.so.1...
Status: RESOLVED MOVED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKit Gtk (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-07-12 06:42 PDT by Fujii Hironori
Modified: 2018-07-21 06:40 PDT (History)
5 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Fujii Hironori 2018-07-12 06:42:40 PDT
Epiphany Technology Preview: error while loading shared libraries: libdw.so.1: cannot open shared object file

I did "flatpak update -y" today. Then Epiphany Technology Preview doesn't start up.

> $ flatpak run org.gnome.Epiphany
> epiphany: error while loading shared libraries: libdw.so.1: cannot open shared object file: No such file or directory

Version:

> $ flatpak info org.gnome.Epiphany
> Ref: app/org.gnome.Epiphany/x86_64/master
> ID: org.gnome.Epiphany
> Arch: x86_64
> Branch: master
> Origin: org.gnome.Epiphany-origin
> Collection ID: 
> Date: 2018-07-11 01:19:51 +0000
> Subject: Build of org.gnome.Epiphany, Wed Jul 11 01:18:48 UTC 2018
> Commit: 19da6185a49ed7e3cf2c7ca3f1a63ab9232ebf09ce465c883176aecc66ada42c
> Parent: 68863ecf43cf58ebc319518c6067e64b85c316c3283e3b5d2ce60d803c76291c
> Location: /var/lib/flatpak/app/org.gnome.Epiphany/x86_64/master/19da6185a49ed7e3cf2c7ca3f1a63ab9232ebf09ce465c883176aecc66ada42c
> Installed size: 7.4 MB
> Runtime: org.gnome.Platform/x86_64/master
> Sdk: org.gnome.Sdk/x86_64/master

I can't find 'epiphany' product to file a new bug in Gnome bugzilla. https://bugzilla.gnome.org/enter_bug.cgi
So, I filed in this bugziila.
Comment 1 Fujii Hironori 2018-07-12 19:44:00 PDT
Tropera told me
https://gitlab.gnome.org/GNOME/epiphany/issues

I should file a bug into it.


  Epiphany nightly throws an error while loading libicuuc.so.61 on ubuntu (#59) · Issues · GNOME / Epiphany · GitLab
  https://gitlab.gnome.org/GNOME/epiphany/issues/59

Looks a similar issue.
Comment 2 Michael Catanzaro 2018-07-14 11:12:30 PDT
(In reply to Fujii Hironori from comment #1)
> Tropera told me
> https://gitlab.gnome.org/GNOME/epiphany/issues
> 
> I should file a bug into it.

Here's fine
Comment 3 Michael Catanzaro 2018-07-14 11:19:34 PDT
Workaround is to downgrade:

$ sudo ostree --repo=/var/lib/flatpak/repo pull --depth=250 --commit-metadata-only org.gnome.Epiphany-origin app/org.gnome.Epiphany/x86_64/master
$ sudo flatpak update --commit=d207851cd549044d21d547a1c80cfc95f651774210346f5c1b22fe645e3594f0 org.gnome.Epiphany

$ sudo ostree --repo=/var/lib/flatpak/repo pull --depth=250 --commit-metadata-only gnome-nightly runtime/org.gnome.Platform/x86_64/master
$ sudo flatpak update --commit=530f7d7e2a28111af5ca97c045cc2141dab445b0600eaa25b76b4647ea1fbc96 org.gnome.Platform

The bug is actually in the runtime, but once that is fixed, it still fails to start due to https://gitlab.gnome.org/GNOME/epiphany/issues/64, so got to downgrade Epiphany too.

Shame that there is no CI to prevent broken builds from going out. :/
Comment 4 Michael Catanzaro 2018-07-14 12:04:43 PDT
libdw.so is in org.gnome.Sdk rather than org.gnome.Platform. As it probably should be. This is a weird dependency and I'm not sure where it came from.
Comment 6 Michael Catanzaro 2018-07-14 12:16:10 PDT
Last good version of org.gnome.Platform is ac1bddfd0ea06cb6429a103ccfe1da5025358a6c908f0c9f2fc5dbb637160d3b (Monday, July 9) and the first bad version is 4922447164197d151ac86e7fd032399a8eb6dc3f1e2279006948d107776435b8 (Tuesday, July 10).
Comment 7 Michael Catanzaro 2018-07-14 12:16:46 PDT
(So it's definitely not caused by adding elfutils.)
Comment 8 Michael Catanzaro 2018-07-14 12:30:28 PDT
Reported https://gitlab.gnome.org/GNOME/gnome-sdk-images/issues/13
Comment 9 Michael Catanzaro 2018-07-14 17:24:10 PDT
We'll track it in https://gitlab.com/freedesktop-sdk/freedesktop-sdk/issues/223
Comment 10 Michael Catanzaro 2018-07-18 07:31:48 PDT
(In reply to Michael Catanzaro from comment #3)
> $ sudo ostree --repo=/var/lib/flatpak/repo pull --depth=250
> --commit-metadata-only org.gnome.Epiphany-origin
> app/org.gnome.Epiphany/x86_64/master
> $ sudo flatpak update
> --commit=d207851cd549044d21d547a1c80cfc95f651774210346f5c1b22fe645e3594f0
> org.gnome.Epiphany

The Epiphany-level bug is fixed, so the above portion of the workaround is no longer required.

The following portion of the workaround is still required, until we get a successful runtime build:
 
$ sudo ostree --repo=/var/lib/flatpak/repo pull --depth=250 --commit-metadata-only gnome-nightly runtime/org.gnome.Platform/x86_64/master
$ sudo flatpak update --commit=530f7d7e2a28111af5ca97c045cc2141dab445b0600eaa25b76b4647ea1fbc96 org.gnome.Platform
Comment 11 Andres Gomez Garcia 2018-07-18 07:45:01 PDT
Or, if you have everything installed as user and not system-wide:

$ ostree --repo=$HOME/.local/share/flatpak/repo/ pull --depth=250 --commit-metadata-only gnome-nightly runtime/org.gnome.Platform/x86_64/master
$ flatpak --user update --commit=530f7d7e2a28111af5ca97c045cc2141dab445b0600eaa25b76b4647ea1fbc96 org.gnome.Platform
Comment 12 Michael Catanzaro 2018-07-20 05:29:53 PDT
I managed to get a successful runtime build, but it doesn't seem to be available yet. Perhaps tomorrow....
Comment 13 Michael Catanzaro 2018-07-21 06:40:35 PDT
Fixed today