Bug 18750 - SQUIRRELFISH: crashes likely caused by incorrect garbage collection
: SQUIRRELFISH: crashes likely caused by incorrect garbage collection
Status: RESOLVED INVALID
Product: WebKit
Classification: Unclassified
Component: JavaScriptCore
: 528+ (Nightly build)
: All All
: P2 Normal
Assigned To: Nobody
:
Depends on:
Blocks: 18631
  Show dependency treegraph
 
Reported: 2008-04-25 18:56 PDT by Cameron Zwarich (cpst)
Modified: 2008-05-03 01:24 PDT (History)
0 users

See Also:


Attachments
Stack trace (4.90 KB, text/plain)
2008-04-25 21:31 PDT, Cameron Zwarich (cpst)
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Cameron Zwarich (cpst) 2008-04-25 18:56:14 PDT
The layout test fast/js/exec-state-marking crashes in a few places, depending on how it is run, but it seems to be caused by incorrect garbage collection. There are similar issues using the web inspector on many pages.
Comment 1 Cameron Zwarich (cpst) 2008-04-25 21:31:14 PDT
Created attachment 20828 [details]
Stack trace

Here is a stack trace from gdb for fast/js/exec-state-marking. I made it GC every allocation.
Comment 2 Maciej Stachowiak 2008-05-03 01:24:34 PDT
This test no longer crashes.