Bug 187378 - REGRESSION(r233496): macOS Sierra hits debug assertions in TrackListBase::suspend
Summary: REGRESSION(r233496): macOS Sierra hits debug assertions in TrackListBase::sus...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Media (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Ryosuke Niwa
URL:
Keywords: InRadar
: 187371 (view as bug list)
Depends on:
Blocks:
 
Reported: 2018-07-05 22:01 PDT by Ryosuke Niwa
Modified: 2018-07-31 19:08 PDT (History)
6 users (show)

See Also:


Attachments
Fixes the bug (5.57 KB, patch)
2018-07-05 23:20 PDT, Ryosuke Niwa
eric.carlson: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Ryosuke Niwa 2018-07-05 22:01:39 PDT
We're seeing debug assertion failures in TrackListBase::suspend after r233496.
Comment 1 Radar WebKit Bug Importer 2018-07-05 22:02:34 PDT
<rdar://problem/41878885>
Comment 2 Radar WebKit Bug Importer 2018-07-05 22:02:51 PDT
<rdar://problem/41878897>
Comment 3 Ryosuke Niwa 2018-07-05 23:20:38 PDT
Created attachment 344404 [details]
Fixes the bug
Comment 4 Ryosuke Niwa 2018-07-05 23:22:49 PDT
Wow, that was very timely review. Thanks!
Comment 5 Ryosuke Niwa 2018-07-06 00:37:52 PDT
Committed r233571: <https://trac.webkit.org/changeset/233571>
Comment 6 Ryosuke Niwa 2018-07-06 19:10:30 PDT
*** Bug 187371 has been marked as a duplicate of this bug. ***
Comment 7 Chris Dumez 2018-07-24 16:13:28 PDT
Reverted r233496 and r233571 for reason:

Likely cause of <rdar://problem/42160890> and <rdar://problem/42329658> as ActiveDOMObjects can now be constructed / destroyed while we are iterating over them.

Committed r234177: <https://trac.webkit.org/changeset/234177>
Comment 8 Ryosuke Niwa 2018-07-31 19:08:57 PDT
Relanded in https://trac.webkit.org/changeset/234374/webkit.