Bug 187071 - [iOS] Rebaseline two webanimations tests after r233164
Summary: [iOS] Rebaseline two webanimations tests after r233164
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Animations (show other bugs)
Version: Other
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2018-06-26 16:47 PDT by Ryan Haddad
Modified: 2018-06-27 00:12 PDT (History)
5 users (show)

See Also:


Attachments
Patch (4.73 KB, patch)
2018-06-26 16:58 PDT, Truitt Savell
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Ryan Haddad 2018-06-26 16:47:04 PDT
The following two tests are failing on iOS Simulator after https://trac.webkit.org/changeset/233164/webkit

Regressions: Unexpected text-only failures (2)
  imported/w3c/web-platform-tests/web-animations/animation-model/animation-types/interpolation-per-property.html [ Failure ]
  webanimations/opacity-animation-yields-compositing-span.html [ Failure ]

It looks like they just need iOS specific baselines, though.
Comment 1 Ryan Haddad 2018-06-26 16:49:42 PDT
imported/w3c/web-platform-tests/web-animations/animation-model/animation-types/interpolation-per-property.html looks like it just needs a line changed to pass:

-FAIL filter: interpolate different length of filter-function-list with function which lacuna value is 0 assert_equals: The value should be opacity(0.5) grayscale(0.5) invert(0.5) sepia(0.5) blur(5px) at 500ms expected "opacity(0.5) grayscale(0.5) invert(0.5) sepia(0.5) blur(5px)" but got "opacity(0.25) grayscale(0.75) invert(0.75) sepia(0.75) blur(7.5px)"
+PASS filter: interpolate different length of filter-function-list with function which lacuna value is 0 

webanimations/opacity-animation-yields-compositing-span.html has a different bounds value:

       (children 1
         (GraphicsLayer
           (position 8.00 8.00)
-          (bounds 25.00 18.00)
+          (bounds 25.00 19.00)
           (opacity 0.50)
           (drawsContent 1)
         )
Comment 2 Ryan Haddad 2018-06-26 16:50:19 PDT
Link to results on a bot:
https://build.webkit.org/results/Apple%20iOS%2011%20Simulator%20Release%20WK2%20(Tests)/r233201%20(5798)/results.html

Let's just go ahead and rebaseline them. Antoine, please let us know if this warrants a bug and we can undo the change.
Comment 3 Truitt Savell 2018-06-26 16:58:47 PDT
Created attachment 343661 [details]
Patch
Comment 4 WebKit Commit Bot 2018-06-26 17:41:37 PDT
Comment on attachment 343661 [details]
Patch

Clearing flags on attachment: 343661

Committed r233233: <https://trac.webkit.org/changeset/233233>
Comment 5 WebKit Commit Bot 2018-06-26 17:41:38 PDT
All reviewed patches have been landed.  Closing bug.
Comment 6 Radar WebKit Bug Importer 2018-06-26 17:43:17 PDT
<rdar://problem/41500291>
Comment 7 Antoine Quint 2018-06-27 00:12:05 PDT
This looks correct Ryan, thanks to you and Truitt for handling this.