Since iOS 12 has seeded, we need to enable the WebKit build for iOS 12.
<rdar://problem/39759057>
Created attachment 343561 [details] Patch
Comment on attachment 343561 [details] Patch I want to start getting this reviewed, working on enabling PDFView now.
Attachment 343561 [details] did not pass style-queue: ERROR: Source/WTF/wtf/spi/darwin/XPCSPI.h:38: xpc_endpoint_t is incorrectly named. Don't use underscores in your identifier names. [readability/naming/underscores] [4] ERROR: Source/WTF/wtf/spi/darwin/XPCSPI.h:106: _xpc_type_connection is incorrectly named. Don't use underscores in your identifier names. [readability/naming/underscores] [4] ERROR: Source/WTF/wtf/spi/darwin/XPCSPI.h:107: _xpc_type_endpoint is incorrectly named. Don't use underscores in your identifier names. [readability/naming/underscores] [4] ERROR: Source/WTF/wtf/spi/darwin/XPCSPI.h:139: xpc_dictionary_set_value is incorrectly named. Don't use underscores in your identifier names. [readability/naming/underscores] [4] ERROR: Source/WTF/wtf/spi/darwin/XPCSPI.h:159: xpc_array_append_value is incorrectly named. Don't use underscores in your identifier names. [readability/naming/underscores] [4] ERROR: Source/WTF/wtf/spi/darwin/XPCSPI.h:160: xpc_data_create is incorrectly named. Don't use underscores in your identifier names. [readability/naming/underscores] [4] ERROR: Source/WTF/wtf/spi/darwin/XPCSPI.h:161: xpc_dictionary_get_array is incorrectly named. Don't use underscores in your identifier names. [readability/naming/underscores] [4] ERROR: Source/WTF/wtf/spi/darwin/XPCSPI.h:162: xpc_data_get_bytes_ptr is incorrectly named. Don't use underscores in your identifier names. [readability/naming/underscores] [4] ERROR: Source/WTF/wtf/spi/darwin/XPCSPI.h:163: xpc_data_get_length is incorrectly named. Don't use underscores in your identifier names. [readability/naming/underscores] [4] ERROR: Source/WTF/wtf/spi/darwin/XPCSPI.h:164: xpc_array_get_value is incorrectly named. Don't use underscores in your identifier names. [readability/naming/underscores] [4] Total errors found: 10 in 25 files If any of these errors are false positives, please file a bug against check-webkit-style.
Created attachment 343626 [details] Patch
Attachment 343626 [details] did not pass style-queue: ERROR: Source/WTF/wtf/spi/darwin/XPCSPI.h:38: xpc_endpoint_t is incorrectly named. Don't use underscores in your identifier names. [readability/naming/underscores] [4] ERROR: Source/WTF/wtf/spi/darwin/XPCSPI.h:106: _xpc_type_connection is incorrectly named. Don't use underscores in your identifier names. [readability/naming/underscores] [4] ERROR: Source/WTF/wtf/spi/darwin/XPCSPI.h:107: _xpc_type_endpoint is incorrectly named. Don't use underscores in your identifier names. [readability/naming/underscores] [4] ERROR: Source/WTF/wtf/spi/darwin/XPCSPI.h:139: xpc_dictionary_set_value is incorrectly named. Don't use underscores in your identifier names. [readability/naming/underscores] [4] ERROR: Source/WTF/wtf/spi/darwin/XPCSPI.h:159: xpc_array_append_value is incorrectly named. Don't use underscores in your identifier names. [readability/naming/underscores] [4] ERROR: Source/WTF/wtf/spi/darwin/XPCSPI.h:160: xpc_data_create is incorrectly named. Don't use underscores in your identifier names. [readability/naming/underscores] [4] ERROR: Source/WTF/wtf/spi/darwin/XPCSPI.h:161: xpc_dictionary_get_array is incorrectly named. Don't use underscores in your identifier names. [readability/naming/underscores] [4] ERROR: Source/WTF/wtf/spi/darwin/XPCSPI.h:162: xpc_data_get_bytes_ptr is incorrectly named. Don't use underscores in your identifier names. [readability/naming/underscores] [4] ERROR: Source/WTF/wtf/spi/darwin/XPCSPI.h:163: xpc_data_get_length is incorrectly named. Don't use underscores in your identifier names. [readability/naming/underscores] [4] ERROR: Source/WTF/wtf/spi/darwin/XPCSPI.h:164: xpc_array_get_value is incorrectly named. Don't use underscores in your identifier names. [readability/naming/underscores] [4] Total errors found: 10 in 27 files If any of these errors are false positives, please file a bug against check-webkit-style.
Comment on attachment 343626 [details] Patch Attachment 343626 [details] did not pass win-ews (win): Output: https://webkit-queues.webkit.org/results/8350179 New failing tests: http/tests/security/canvas-remote-read-remote-video-blocked-no-crossorigin.html
Created attachment 343637 [details] Archive of layout-test-results from ews206 for win-future The attached test failures were seen while running run-webkit-tests on the win-ews. Bot: ews206 Port: win-future Platform: CYGWIN_NT-6.1-2.9.0-0.318-5-3-x86_64-64bit
We're going to need to make some changes to our .xcconfig files for embedded builds, but I will delay that until these changes land.
Comment on attachment 343626 [details] Patch View in context: https://bugs.webkit.org/attachment.cgi?id=343626&action=review r=me > Source/WTF/wtf/spi/darwin/XPCSPI.h:107 > extern const struct _xpc_type_s _xpc_type_dictionary; > extern const struct _xpc_type_s _xpc_type_error; > extern const struct _xpc_type_s _xpc_type_string; > +extern const struct _xpc_type_s _xpc_type_connection; > +extern const struct _xpc_type_s _xpc_type_endpoint; Nit: Alphabetize. > Source/WTF/wtf/spi/darwin/XPCSPI.h:139 > void xpc_dictionary_set_fd(xpc_object_t, const char* key, int fd); > void xpc_dictionary_set_string(xpc_object_t, const char* key, const char* string); > void xpc_dictionary_set_uint64(xpc_object_t, const char* key, uint64_t value); > -void xpc_dictionary_set_value(xpc_object_t, const char*key, xpc_object_t value); > +void xpc_dictionary_set_value(xpc_object_t, const char *key, xpc_object_t value); Nit: Please put the space to the right of the '*'. > Source/WTF/wtf/spi/darwin/XPCSPI.h:164 > +void xpc_array_append_value(xpc_object_t xarray, xpc_object_t value); > +xpc_object_t xpc_data_create(const void* bytes, size_t length); > +xpc_object_t xpc_dictionary_get_array(xpc_object_t xdict, const char* key); > +const void * xpc_data_get_bytes_ptr(xpc_object_t xdata); > +size_t xpc_data_get_length(xpc_object_t xdata); > +xpc_object_t xpc_array_get_value(xpc_object_t xarray, size_t index); NitL Alphabetize. > Source/WebKit/Platform/spi/ios/PDFKitSPI.h:53 > ++ (void) createHostView: (void(^)( PDFHostViewController* hostViewController )) callback forExtensionIdentifier: (NSString*) extensionIdentifier; > +- (void) setDelegate: (id<PDFHostViewControllerDelegate>) delegate; > +- (void) setDocumentData: (NSData*) data withScrollView: (UIScrollView*) scrollView; > + > +- (void) findString: (NSString*) string withOptions: (NSStringCompareOptions) options; > +- (void) cancelFindString; > +- (void) focusOnSearchResultAtIndex: (NSUInteger) searchIndex; > + > +- (NSInteger) currentPageIndex; > +- (NSInteger) pageCount; > +- (UIView*) pageNumberIndicator; > +- (void) goToPageIndex: (NSInteger) pageIndex; Nit: No spaces between the colon and the left parenthesis please: - (void) goToPageIndex:(NSInteger) pageIndex; > Source/WebKit/Platform/spi/ios/UIKitSPI.h:976 > +typedef NS_ENUM(NSInteger, UICompositingMode) { > + UICompositingModeNormal, > + UICompositingModeMultiply, > + UICompositingModeScreen, > + UICompositingModeOverlay, > + UICompositingModeDarken, > + UICompositingModeLighten, > + UICompositingModeColorDodge, > + UICompositingModeColorBurn, > + UICompositingModeSoftLight, > + UICompositingModeHardLight, > + UICompositingModeDifference, > + UICompositingModeExclusion, > + UICompositingModeClear, > + UICompositingModeCopy, > + UICompositingModeSourceIn, > + UICompositingModeSourceOut, > + UICompositingModeSourceAtop, > + UICompositingModeDestination, > + UICompositingModeDestinationOver, > + UICompositingModeDestinationIn, > + UICompositingModeDestinationOut, > + UICompositingModeDestinationAtop, > + UICompositingModeXOR, > + UICompositingModePlusDarker, > + UICompositingModePlusLighter, > +}; Do we need all of these? I guess we need placeholders if we don't declare them all. > WebKitLibraries/WebKitPrivateFrameworkStubs/iOS/12/AppSupport.framework/AppSupport.tbd:4 > + - armv7 > + - armv7s Are you sure we need armv7 and armv7s anymore? Do we need armv7k for watchOS? > WebKitLibraries/WebKitPrivateFrameworkStubs/iOS/12/AppSupport.framework/AppSupport.tbd:12 > + - armv7 > + - armv7s Ditto.
Created attachment 343663 [details] Patch
I intend to land this tomorrow when I can monitor the bots.
Attachment 343663 [details] did not pass style-queue: ERROR: Source/WTF/wtf/spi/darwin/XPCSPI.h:38: xpc_endpoint_t is incorrectly named. Don't use underscores in your identifier names. [readability/naming/underscores] [4] ERROR: Source/WTF/wtf/spi/darwin/XPCSPI.h:103: _xpc_type_connection is incorrectly named. Don't use underscores in your identifier names. [readability/naming/underscores] [4] ERROR: Source/WTF/wtf/spi/darwin/XPCSPI.h:105: _xpc_type_endpoint is incorrectly named. Don't use underscores in your identifier names. [readability/naming/underscores] [4] ERROR: Source/WTF/wtf/spi/darwin/XPCSPI.h:139: xpc_dictionary_set_value is incorrectly named. Don't use underscores in your identifier names. [readability/naming/underscores] [4] ERROR: Source/WTF/wtf/spi/darwin/XPCSPI.h:159: xpc_array_append_value is incorrectly named. Don't use underscores in your identifier names. [readability/naming/underscores] [4] ERROR: Source/WTF/wtf/spi/darwin/XPCSPI.h:160: xpc_array_get_value is incorrectly named. Don't use underscores in your identifier names. [readability/naming/underscores] [4] ERROR: Source/WTF/wtf/spi/darwin/XPCSPI.h:161: xpc_data_create is incorrectly named. Don't use underscores in your identifier names. [readability/naming/underscores] [4] ERROR: Source/WTF/wtf/spi/darwin/XPCSPI.h:162: xpc_data_get_bytes_ptr is incorrectly named. Don't use underscores in your identifier names. [readability/naming/underscores] [4] ERROR: Source/WTF/wtf/spi/darwin/XPCSPI.h:163: xpc_data_get_length is incorrectly named. Don't use underscores in your identifier names. [readability/naming/underscores] [4] ERROR: Source/WTF/wtf/spi/darwin/XPCSPI.h:164: xpc_dictionary_get_array is incorrectly named. Don't use underscores in your identifier names. [readability/naming/underscores] [4] Total errors found: 10 in 27 files If any of these errors are false positives, please file a bug against check-webkit-style.
Comment on attachment 343663 [details] Patch Clearing flags on attachment: 343663 Committed r233266: <https://trac.webkit.org/changeset/233266>
All reviewed patches have been landed. Closing bug.
<rdar://problem/41532787>
Reopening to attach new patch.
Created attachment 343759 [details] Patch
Some build breakage, working to verify this fix before landing.
Committed r233283: <https://trac.webkit.org/changeset/233283>
Created attachment 343830 [details] Patch
More build breakage on unrelated platforms.
Committed r233327: <https://trac.webkit.org/changeset/233327>