Bug 186911 - [CMake] Generated sources depending on SelectorPseudoClassAndCompatibilityElementMap.in are not regenerated
Summary: [CMake] Generated sources depending on SelectorPseudoClassAndCompatibilityEle...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebCore Misc. (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords: Gtk, InRadar, LayoutTestFailure
Depends on:
Blocks:
 
Reported: 2018-06-22 00:40 PDT by Carlos Garcia Campos
Modified: 2018-06-22 06:23 PDT (History)
3 users (show)

See Also:


Attachments
Patch (2.73 KB, patch)
2018-06-22 00:42 PDT, Carlos Garcia Campos
mcatanzaro: review+
Details | Formatted Diff | Diff
Archive of layout-test-results from ews114 for mac-sierra (3.00 MB, application/zip)
2018-06-22 02:19 PDT, Build Bot
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Carlos Garcia Campos 2018-06-22 00:40:01 PDT
This is causing test fullscreen/fullscreen-env.html to fail since it was added in r233066 in the bots that didn't start a clean build. The problem is that the CMake command to generate SelectorPseudoClassAndCompatibilityElementMap.cpp doesn't depend on SelectorPseudoClassAndCompatibilityElementMap.in.
Comment 1 Carlos Garcia Campos 2018-06-22 00:42:03 PDT
Created attachment 343312 [details]
Patch
Comment 2 Build Bot 2018-06-22 02:19:51 PDT
Comment on attachment 343312 [details]
Patch

Attachment 343312 [details] did not pass mac-debug-ews (mac):
Output: https://webkit-queues.webkit.org/results/8287887

New failing tests:
performance-api/performance-observer-no-document-leak.html
Comment 3 Build Bot 2018-06-22 02:19:53 PDT
Created attachment 343314 [details]
Archive of layout-test-results from ews114 for mac-sierra

The attached test failures were seen while running run-webkit-tests on the mac-debug-ews.
Bot: ews114  Port: mac-sierra  Platform: Mac OS X 10.12.6
Comment 4 Carlos Garcia Campos 2018-06-22 06:22:23 PDT
Committed r233076: <https://trac.webkit.org/changeset/233076>
Comment 5 Radar WebKit Bug Importer 2018-06-22 06:23:19 PDT
<rdar://problem/41365998>