Bug 18645 - Cross-scope access (e.g. function access to globals) is not optimized in SquirrelFish
Summary: Cross-scope access (e.g. function access to globals) is not optimized in Squi...
Status: RESOLVED DUPLICATE of bug 19116
Alias: None
Product: WebKit
Classification: Unclassified
Component: JavaScriptCore (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh OS X 10.5
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-04-20 16:43 PDT by Maciej Stachowiak
Modified: 2008-05-25 22:01 PDT (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Maciej Stachowiak 2008-04-20 16:43:54 PDT
Cross-scope access (e.g. function access to globals) is not optimized in SquirrelFish. This was a valuable optimization that we had in the trunk version of the engine and should at some point be restored.
Comment 1 Oliver Hunt 2008-05-25 22:01:19 PDT

*** This bug has been marked as a duplicate of 19116 ***