Bug 186315 - SVG <image> elements don't dislpay image
Summary: SVG <image> elements don't dislpay image
Status: RESOLVED DUPLICATE of bug 153854
Alias: None
Product: WebKit
Classification: Unclassified
Component: SVG (show other bugs)
Version: Safari 11
Hardware: All All
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-06-05 12:17 PDT by shayneosull
Modified: 2018-06-05 12:37 PDT (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description shayneosull 2018-06-05 12:17:02 PDT
Loading a .png or .jpg as an <image> element within an SVG does not work. See example failing here: https://developer.mozilla.org/en-US/docs/Web/SVG/Element/image
Comment 1 Said Abou-Hallawa 2018-06-05 12:37:33 PDT
This happens because SVG 2 does not require the xlink namespace before the href attribute.

For example, this tag will not show the image in WebKit

<image href="https://mdn.mozillademos.org/files/6457/mdn_logo_only_color.png" height="200" width="200"/>

But this tag will show it because WebKit still supports SVG 1 only:

<image xlink:href="https://mdn.mozillademos.org/files/6457/mdn_logo_only_color.png" height="200" width="200"/>

*** This bug has been marked as a duplicate of bug 153854 ***