NEW 186198
Move OpenGL display mask to screen data struct.
https://bugs.webkit.org/show_bug.cgi?id=186198
Summary Move OpenGL display mask to screen data struct.
Per Arne Vollan
Reported 2018-06-01 09:38:12 PDT
In order for individual web views to have the correct OpenGL mask set, it should no be a global, but be moved into the Chrome class.
Attachments
Patch (34.41 KB, patch)
2018-06-02 18:08 PDT, Per Arne Vollan
ews-watchlist: commit-queue-
Archive of layout-test-results from ews206 for win-future (12.75 MB, application/zip)
2018-06-03 00:31 PDT, EWS Watchlist
no flags
Patch (35.86 KB, patch)
2018-06-04 13:08 PDT, Per Arne Vollan
no flags
Patch (40.66 KB, patch)
2018-06-04 15:51 PDT, Per Arne Vollan
no flags
Patch (41.07 KB, patch)
2018-06-04 16:17 PDT, Per Arne Vollan
no flags
Patch (42.83 KB, patch)
2018-06-04 16:29 PDT, Per Arne Vollan
no flags
Patch (43.06 KB, patch)
2018-06-04 16:45 PDT, Per Arne Vollan
no flags
Patch (41.55 KB, patch)
2018-06-04 19:47 PDT, Per Arne Vollan
no flags
Patch (43.35 KB, patch)
2018-06-05 09:32 PDT, Per Arne Vollan
no flags
Patch (43.58 KB, patch)
2018-06-05 09:54 PDT, Per Arne Vollan
bfulgham: review+
Patch (43.03 KB, patch)
2018-06-05 13:33 PDT, Per Arne Vollan
pvollan: commit-queue-
Patch (43.10 KB, patch)
2018-06-05 14:30 PDT, Per Arne Vollan
no flags
Patch (43.10 KB, patch)
2018-06-05 19:36 PDT, Per Arne Vollan
no flags
Radar WebKit Bug Importer
Comment 1 2018-06-01 10:04:26 PDT
Per Arne Vollan
Comment 2 2018-06-02 18:08:43 PDT
EWS Watchlist
Comment 3 2018-06-02 18:10:53 PDT
Attachment 341858 [details] did not pass style-queue: ERROR: Source/WebCore/platform/graphics/cocoa/IOSurface.h:110: The parameter name "hostWindow" adds no information, so it should be removed. [readability/parameter_name] [5] ERROR: Source/WebCore/platform/graphics/ImageBuffer.h:69: The parameter name "hostWindow" adds no information, so it should be removed. [readability/parameter_name] [5] ERROR: Source/WebCore/platform/graphics/ImageBuffer.h:170: The parameter name "hostWindow" adds no information, so it should be removed. [readability/parameter_name] [5] ERROR: Source/WebCore/page/Chrome.h:183: The parameter name "displayMask" adds no information, so it should be removed. [readability/parameter_name] [5] ERROR: Source/WebCore/platform/graphics/GraphicsContext3D.h:1319: The parameter name "hostWindow" adds no information, so it should be removed. [readability/parameter_name] [5] Total errors found: 5 in 25 files If any of these errors are false positives, please file a bug against check-webkit-style.
EWS Watchlist
Comment 4 2018-06-03 00:31:18 PDT
Comment on attachment 341858 [details] Patch Attachment 341858 [details] did not pass win-ews (win): Output: http://webkit-queues.webkit.org/results/7956074 New failing tests: http/tests/security/canvas-remote-read-remote-video-blocked-no-crossorigin.html
EWS Watchlist
Comment 5 2018-06-03 00:31:30 PDT
Created attachment 341862 [details] Archive of layout-test-results from ews206 for win-future The attached test failures were seen while running run-webkit-tests on the win-ews. Bot: ews206 Port: win-future Platform: CYGWIN_NT-6.1-2.9.0-0.318-5-3-x86_64-64bit
Per Arne Vollan
Comment 6 2018-06-04 13:08:48 PDT
Per Arne Vollan
Comment 7 2018-06-04 15:51:52 PDT
Per Arne Vollan
Comment 8 2018-06-04 16:17:57 PDT
Per Arne Vollan
Comment 9 2018-06-04 16:29:14 PDT
Per Arne Vollan
Comment 10 2018-06-04 16:45:49 PDT
Per Arne Vollan
Comment 11 2018-06-04 19:47:13 PDT
Per Arne Vollan
Comment 12 2018-06-05 09:32:52 PDT
Per Arne Vollan
Comment 13 2018-06-05 09:54:28 PDT
Brent Fulgham
Comment 14 2018-06-05 10:31:37 PDT
Comment on attachment 341972 [details] Patch View in context: https://bugs.webkit.org/attachment.cgi?id=341972&action=review Can you create a TestWebkitAPI test to confirm the right mask goes to the right WebView? We might not have infrastructure to support that. > Source/WebCore/platform/mac/PlatformScreenMac.mm:138 > + screenProperties.primaryOpenGLDisplayMask = displayMask; You might not need this special case if you used "screenData(primaryScreenDisplayID()).displayMask" as the implementation elsewhere. > Source/WebCore/platform/mac/PlatformScreenMac.mm:167 > + return screenProperties().primaryOpenGLDisplayMask; This could also be: return screenData(primaryScreenDisplayID()).displayMask; But perhaps this code path is hit frequently enough that you don't want to do the extra lookups?
Brent Fulgham
Comment 15 2018-06-05 12:33:40 PDT
Comment on attachment 341972 [details] Patch Per Arne and I spoke in person, and I think this patch is correct. We will file a bug about multiple-display test support and building up testing infrastructure to support such things.
Per Arne Vollan
Comment 16 2018-06-05 13:33:45 PDT
Per Arne Vollan
Comment 17 2018-06-05 14:30:27 PDT
Per Arne Vollan
Comment 18 2018-06-05 19:36:13 PDT
WebKit Commit Bot
Comment 19 2018-06-05 21:35:18 PDT
Comment on attachment 342022 [details] Patch Clearing flags on attachment: 342022 Committed r232535: <https://trac.webkit.org/changeset/232535>
Note You need to log in before you can comment on or make changes to this bug.