Bug 185865 - Fix build without MathML
Summary: Fix build without MathML
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebCore Misc. (show other bugs)
Version: Other
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2018-05-22 05:42 PDT by Olivier Blin
Modified: 2018-05-22 07:47 PDT (History)
9 users (show)

See Also:


Attachments
Patch (6.14 KB, patch)
2018-05-22 05:43 PDT, Olivier Blin
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Olivier Blin 2018-05-22 05:42:24 PDT
Build without ENABLE(MATHML) fails.

Regression(r226654): [RenderTreeBuilder] Move MathML addChild logic to RenderTreeBuilder
https://bugs.webkit.org/show_bug.cgi?id=181443

Regression(r229694): Put the DOM in IsoHeaps
https://bugs.webkit.org/show_bug.cgi?id=183546
Comment 1 Olivier Blin 2018-05-22 05:43:53 PDT
Created attachment 340976 [details]
Patch
Comment 2 Olivier Blin 2018-05-22 05:54:22 PDT
You may want to know if it is still worth maintaining this MathML build flag.

On an ARMv7 platform, disabling MathML allows to save 242,148 bytes over a library of 27,063,644 bytes, that's about 1% of the size.
Comment 3 Michael Catanzaro 2018-05-22 07:19:45 PDT
Comment on attachment 340976 [details]
Patch

Sigh, I think it's OK even without exposing the MATHML build flag for WPE, because none of the code is platform-specific.
Comment 4 Michael Catanzaro 2018-05-22 07:20:41 PDT
(In reply to Olivier Blin from comment #2)
> You may want to know if it is still worth maintaining this MathML build flag.
> 
> On an ARMv7 platform, disabling MathML allows to save 242,148 bytes over a
> library of 27,063,644 bytes, that's about 1% of the size.

And yes, if you didn't have this analysis to prove it's significant, we would have probably started to talk about that.
Comment 5 WebKit Commit Bot 2018-05-22 07:46:47 PDT
Comment on attachment 340976 [details]
Patch

Clearing flags on attachment: 340976

Committed r232064: <https://trac.webkit.org/changeset/232064>
Comment 6 WebKit Commit Bot 2018-05-22 07:46:49 PDT
All reviewed patches have been landed.  Closing bug.
Comment 7 Radar WebKit Bug Importer 2018-05-22 07:47:15 PDT
<rdar://problem/40450626>