Bug 185804 - BooleanLattice should be a class
Summary: BooleanLattice should be a class
Status: NEW
Alias: None
Product: WebKit
Classification: Unclassified
Component: Web Template Framework (show other bugs)
Version: WebKit Nightly Build
Hardware: All All
: P2 Normal
Assignee: Nobody
Depends on: 185695
  Show dependency treegraph
Reported: 2018-05-19 12:57 PDT by Filip Pizlo
Modified: 2018-05-19 12:57 PDT (History)
0 users

See Also:


Note You need to log in before you can comment on or make changes to this bug.
Description Filip Pizlo 2018-05-19 12:57:32 PDT
This would work a lot better as a class with methods. Then we could ensure that the default value is always Bottom, we could have nice conversions to and from boolean, and things like the leastUpperBound function could be a member function with a nicer name.