Bug 18579 - REGRESSION: www.idg.se causes WebKit to freeze.
Summary: REGRESSION: www.idg.se causes WebKit to freeze.
Status: RESOLVED WORKSFORME
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh OS X 10.5
: P1 Major
Assignee: Nobody
URL: http://www.idg.se
Keywords:
Depends on:
Blocks:
 
Reported: 2008-04-18 04:27 PDT by Leonard W.
Modified: 2008-11-16 23:40 PST (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Leonard W. 2008-04-18 04:27:02 PDT
Domain: www.idg.se
Nightly build r32012
Local safari version: 3.1.1 (5525.18)

Hardware:
Macbook Pro Core Duo 2.16 GHz
2048 MB RAM
Radeon x1600

WebKit becomes irresponsive and needs to be quit forcefully.
It is a recurring issue. However it appears to happen in random occasions.

I attached Drosera to WebKit before loading up www.idg.se. Doing a few pauses, I was able to see that numerous of
javascript functions were being executed. I stepped out of these functions using the same app, and was shortly thereafter informed that a script was making the browser irresponsive.  I clicked "Stop", and hoped to regain control over WebKit, but the freeze was already a fact.

By forcefully quit WebKit, I received the following Stack trace:

http://muspelheim.lurvas.org/~zanathel/__MAC/StackTrace.txt
Comment 1 Alexey Proskuryakov 2008-04-21 08:33:14 PDT
From the stack trace, this looks like it may be a Flash plug-in issue. Would installing an update from <http://www.adobe.com/products/flashplayer> resolve this for you?
Comment 2 garglebutt 2008-11-16 04:29:30 PST
Latest nightly Nov 14 and Shockwave Flash 9.0 r124 had no issues with this site.
Comment 3 garglebutt 2008-11-16 04:39:47 PST
Latest nightly Nov 14 and Shockwave Flash 10.0 r12 had no issues with this
site. Some flash movies on IDG-TV tab played fine.
Comment 4 Alexey Proskuryakov 2008-11-16 23:40:26 PST
So, WORKSFORME - thank you!