Bug 185698 - Layout Test svg/dom/animated-tearoff-list-remove-target.html is a flaky timeout
Summary: Layout Test svg/dom/animated-tearoff-list-remove-target.html is a flaky timeout
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: Other
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Said Abou-Hallawa
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2018-05-16 15:11 PDT by Ryan Haddad
Modified: 2018-06-12 15:30 PDT (History)
10 users (show)

See Also:


Attachments
Patch (3.91 KB, patch)
2018-06-08 11:45 PDT, Said Abou-Hallawa
no flags Details | Formatted Diff | Diff
Archive of layout-test-results from ews106 for mac-sierra-wk2 (3.32 MB, application/zip)
2018-06-08 14:26 PDT, Build Bot
no flags Details
Patch (3.79 KB, patch)
2018-06-08 17:19 PDT, Said Abou-Hallawa
no flags Details | Formatted Diff | Diff
Patch (3.75 KB, patch)
2018-06-11 13:46 PDT, Said Abou-Hallawa
no flags Details | Formatted Diff | Diff
Patch (3.75 KB, patch)
2018-06-11 15:05 PDT, Said Abou-Hallawa
no flags Details | Formatted Diff | Diff
Patch (3.75 KB, patch)
2018-06-11 16:43 PDT, Said Abou-Hallawa
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Ryan Haddad 2018-05-16 15:11:02 PDT
Layout Test svg/dom/animated-tearoff-list-remove-target.html is a flaky timeout on macOS Debug WK1 and iOS Simulator Debug WK2

Probable cause:

Unknown.

Flakiness Dashboard:

https://webkit-test-results.webkit.org/dashboards/flakiness_dashboard.html#showAllRuns=true&tests=svg%2Fdom%2Fanimated-tearoff-list-remove-target.html
Comment 1 Ryan Haddad 2018-05-16 15:12:26 PDT
This test was added in https://trac.webkit.org/changeset/230172/webkit
Comment 2 Radar WebKit Bug Importer 2018-05-17 12:54:40 PDT
<rdar://problem/40341200>
Comment 3 Said Abou-Hallawa 2018-06-08 11:45:59 PDT
Created attachment 342301 [details]
Patch
Comment 4 Build Bot 2018-06-08 14:26:51 PDT
Comment on attachment 342301 [details]
Patch

Attachment 342301 [details] did not pass mac-wk2-ews (mac-wk2):
Output: http://webkit-queues.webkit.org/results/8087634

New failing tests:
accessibility/smart-invert-reference.html
Comment 5 Build Bot 2018-06-08 14:26:53 PDT
Created attachment 342331 [details]
Archive of layout-test-results from ews106 for mac-sierra-wk2

The attached test failures were seen while running run-webkit-tests on the mac-wk2-ews.
Bot: ews106  Port: mac-sierra-wk2  Platform: Mac OS X 10.12.6
Comment 6 Ryosuke Niwa 2018-06-08 14:29:44 PDT
Comment on attachment 342301 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=342301&action=review

> LayoutTests/svg/dom/animated-tearoff-list-remove-target.html:54
> +            }, 50);

Are we waiting for the animation to occur? If so, can we make this more deterministic by using requestAnimationFrame instead?
Comment 7 Said Abou-Hallawa 2018-06-08 17:19:52 PDT
Created attachment 342349 [details]
Patch
Comment 8 Said Abou-Hallawa 2018-06-08 17:20:22 PDT
Comment on attachment 342301 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=342301&action=review

>> LayoutTests/svg/dom/animated-tearoff-list-remove-target.html:54
>> +            }, 50);
> 
> Are we waiting for the animation to occur? If so, can we make this more deterministic by using requestAnimationFrame instead?

Yes. Done.
Comment 9 Daniel Bates 2018-06-11 13:36:56 PDT
Comment on attachment 342349 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=342349&action=review

> LayoutTests/ChangeLog:22
> +        Reviewed by NOBODY (OOPS!).

This line should be before the description (line 7).
Comment 10 Said Abou-Hallawa 2018-06-11 13:46:42 PDT
Created attachment 342460 [details]
Patch
Comment 11 Said Abou-Hallawa 2018-06-11 15:05:20 PDT
Created attachment 342468 [details]
Patch
Comment 12 Said Abou-Hallawa 2018-06-11 16:43:24 PDT
Created attachment 342482 [details]
Patch
Comment 13 WebKit Commit Bot 2018-06-11 17:11:09 PDT
Comment on attachment 342482 [details]
Patch

Clearing flags on attachment: 342482

Committed r232736: <https://trac.webkit.org/changeset/232736>
Comment 14 WebKit Commit Bot 2018-06-11 17:11:10 PDT
All reviewed patches have been landed.  Closing bug.
Comment 15 Ryan Haddad 2018-06-12 14:19:41 PDT
The test is no longer a flaky timeout, but now it is a flaky failure on iOS and macOS :(

--- /Volumes/Data/slave/highsierra-leaks/build/layout-test-results/svg/dom/animated-tearoff-list-remove-target-expected.txt
+++ /Volumes/Data/slave/highsierra-leaks/build/layout-test-results/svg/dom/animated-tearoff-list-remove-target-actual.txt
@@ -1,4 +1,4 @@
 Removing the target of an animate element should detach the wrappers of the attributes from their animated properties.
+First tspan.
+Second tspan
 
-PASS.
-

https://build.webkit.org/results/Apple%20Sierra%20Release%20WK1%20(Tests)/r232770%20(10781)/results.html
Comment 16 Said Abou-Hallawa 2018-06-12 15:30:27 PDT
I think the issue is fixed by the followup patch: <https://trac.webkit.org/changeset/232780>.