Bug 185653 - Fix crash after a Worker terminates but there are still IDB transactions the server is trying to open for it
Summary: Fix crash after a Worker terminates but there are still IDB transactions the ...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebCore Misc. (show other bugs)
Version: Other
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Brady Eidson
URL:
Keywords: InRadar
: 188796 (view as bug list)
Depends on:
Blocks:
 
Reported: 2018-05-15 11:08 PDT by Brady Eidson
Modified: 2018-08-21 15:33 PDT (History)
7 users (show)

See Also:


Attachments
Patch (5.54 KB, patch)
2018-05-15 11:11 PDT, Brady Eidson
no flags Details | Formatted Diff | Diff
Patch (6.11 KB, patch)
2018-05-15 11:29 PDT, Brady Eidson
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Brady Eidson 2018-05-15 11:08:15 PDT
Fix crash after a Worker terminates but there are still IDB transactions the server is trying to open for it

<rdar://problem/33744241>
Comment 1 Brady Eidson 2018-05-15 11:11:31 PDT
Created attachment 340421 [details]
Patch
Comment 2 Andy Estes 2018-05-15 11:26:14 PDT
Comment on attachment 340421 [details]
Patch

missing an expected result. r=me otherwise.
Comment 3 Brady Eidson 2018-05-15 11:29:18 PDT
Created attachment 340422 [details]
Patch
Comment 4 WebKit Commit Bot 2018-05-15 12:07:18 PDT
Comment on attachment 340422 [details]
Patch

Clearing flags on attachment: 340422

Committed r231812: <https://trac.webkit.org/changeset/231812>
Comment 5 WebKit Commit Bot 2018-05-15 12:07:20 PDT
All reviewed patches have been landed.  Closing bug.
Comment 6 Alexey Proskuryakov 2018-08-21 15:33:03 PDT
*** Bug 188796 has been marked as a duplicate of this bug. ***