Bug 185504 - [GTK] Webpage becomes white after loaded
Summary: [GTK] Webpage becomes white after loaded
Status: RESOLVED INVALID
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKitGTK (show other bugs)
Version: WebKit Nightly Build
Hardware: PC Linux
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-05-09 18:59 PDT by Michael Catanzaro
Modified: 2018-05-19 09:49 PDT (History)
4 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Catanzaro 2018-05-09 18:59:19 PDT
Visit this webpage in Ephy Tech Preview:

http://www.urbanreviewstl.com/2018/05/opinion-st-louis-government-structure-has-failed-cityregion-and-generations-of-most-vulnerable-residents/
 
The page content loads, then a brief instant later the web view becomes fully white.

We've seen this before on at least one other website, but I'm not sure where the original bug reports is.
Comment 1 Carlos Eduardo Ramalho 2018-05-10 06:05:30 PDT
I can reproduce it every time with Epiphany TP, but not once with MiniBrowser in Debug or Release mode. This is odd.
Comment 2 Michael Catanzaro 2018-05-10 07:28:03 PDT
Interesting, you're right that it doesn't happen in MiniBrowser, even with the Tech Preview versions of everything. Test:

$ flatpak run --devel --command=/bin/bash org.gnome.Epiphany
$ /usr/libexec/webkit2gtk-4.0/MiniBrowser

MiniBrowser handles it fine even with some tabs created.
Comment 3 Michael Catanzaro 2018-05-10 07:39:06 PDT
It's caused by Epiphany's adblocker.
Comment 4 Michael Catanzaro 2018-05-19 09:49:26 PDT
It's caused by the Fanboy Annoyance List, https://bugzilla.gnome.org/show_bug.cgi?id=796245