Bug 185148 - AX: [AOM] Turn Accessibility Object Model on by default
Summary: AX: [AOM] Turn Accessibility Object Model on by default
Status: RESOLVED WONTFIX
Alias: None
Product: WebKit
Classification: Unclassified
Component: Accessibility (show other bugs)
Version: WebKit Nightly Build
Hardware: All All
: P2 Normal
Assignee: Nobody
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2018-04-30 15:27 PDT by Nan Wang
Modified: 2019-04-24 18:02 PDT (History)
6 users (show)

See Also:


Attachments
patch (2.26 KB, patch)
2018-04-30 15:52 PDT, Nan Wang
no flags Details | Formatted Diff | Diff
patch (2.23 KB, patch)
2018-04-30 15:54 PDT, Nan Wang
rniwa: review-
ews: commit-queue-
Details | Formatted Diff | Diff
Archive of layout-test-results from ews200 for win-future (12.81 MB, application/zip)
2018-04-30 17:45 PDT, Build Bot
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Nan Wang 2018-04-30 15:27:42 PDT
[AOM] Turn Accessibility Object Model on by default
Comment 1 Radar WebKit Bug Importer 2018-04-30 15:27:55 PDT
<rdar://problem/39851277>
Comment 2 Nan Wang 2018-04-30 15:52:57 PDT
Created attachment 339156 [details]
patch
Comment 3 Build Bot 2018-04-30 15:53:39 PDT
Attachment 339156 [details] did not pass style-queue:


ERROR: Source/WebCore/ChangeLog:9:  You should remove the 'No new tests' and either add and list tests, or explain why no new tests were possible.  [changelog/nonewtests] [5]
Total errors found: 1 in 4 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 4 Nan Wang 2018-04-30 15:54:05 PDT
Created attachment 339158 [details]
patch
Comment 5 Build Bot 2018-04-30 17:45:10 PDT
Comment on attachment 339158 [details]
patch

Attachment 339158 [details] did not pass win-ews (win):
Output: http://webkit-queues.webkit.org/results/7517034

New failing tests:
http/tests/preload/onload_event.html
Comment 6 Build Bot 2018-04-30 17:45:22 PDT
Created attachment 339167 [details]
Archive of layout-test-results from ews200 for win-future

The attached test failures were seen while running run-webkit-tests on the win-ews.
Bot: ews200  Port: win-future  Platform: CYGWIN_NT-6.1-2.9.0-0.318-5-3-x86_64-64bit
Comment 7 Nan Wang 2018-05-01 10:46:24 PDT
I don't think the win test failure is related.
Comment 8 Ryosuke Niwa 2018-05-01 10:55:47 PDT
Do we have the spec compliant implementation of all the APIs we want for phase 1?
Comment 9 Ryosuke Niwa 2018-05-01 15:42:02 PDT
Comment on attachment 339158 [details]
patch

r=me assuming this only turns on AOM events, and other related features like DOM reflections, etc...
Comment 10 Ryosuke Niwa 2018-05-02 17:11:02 PDT
Comment on attachment 339158 [details]
patch

I think we want to do this later per email discussion.
Comment 11 James Craig 2019-04-24 18:02:20 PDT
Obsolete.