Bug 184780 - [GTK] fast/repaint/fixed-scale.html failing since r230479 "[TexMap] TextureMapperLayer unnecessarily duplicates state in GraphicsLayerTransform"
Summary: [GTK] fast/repaint/fixed-scale.html failing since r230479 "[TexMap] TextureMa...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKitGTK (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Miguel Gomez
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-04-19 07:49 PDT by Miguel Gomez
Modified: 2018-04-25 06:08 PDT (History)
9 users (show)

See Also:


Attachments
Patch (2.97 KB, patch)
2018-04-25 05:15 PDT, Miguel Gomez
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Miguel Gomez 2018-04-19 07:49:54 PDT
fast/repaint/fixed-scale.html [ ImageOnlyFailure ]

diff here

https://build.webkit.org/results/GTK%20Linux%2064-bit%20Release%20(Tests)/r230797%20(6339)/fast/repaint/fixed-scale-diffs.html
Comment 1 Miguel Gomez 2018-04-25 05:15:17 PDT
The problem is that the anchor point used in GraphicsLayerTransform was initialized to (0.5, 0.5, 0) when used for transformation calculations, but now that we don't use that class, it's being initialized to (0, 0, 0), causing some transformations to produce buggy results.
Comment 2 Miguel Gomez 2018-04-25 05:15:47 PDT
Created attachment 338720 [details]
Patch
Comment 3 WebKit Commit Bot 2018-04-25 06:08:56 PDT
Comment on attachment 338720 [details]
Patch

Clearing flags on attachment: 338720

Committed r230991: <https://trac.webkit.org/changeset/230991>
Comment 4 WebKit Commit Bot 2018-04-25 06:08:58 PDT
All reviewed patches have been landed.  Closing bug.