Bug 184642 - [MSE] New SourceBuffers Objects from WebCore/JavaScript
Summary: [MSE] New SourceBuffers Objects from WebCore/JavaScript
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebCore JavaScript (show other bugs)
Version: WebKit Nightly Build
Hardware: All All
: P2 Normal
Assignee: Nobody
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2018-04-15 22:03 PDT by Eric Stobbart
Modified: 2018-04-19 09:04 PDT (History)
4 users (show)

See Also:


Attachments
Patch (1.37 KB, patch)
2018-04-15 22:05 PDT, Eric Stobbart
no flags Details | Formatted Diff | Diff
Patch (3.64 KB, patch)
2018-04-16 06:34 PDT, Eric Stobbart
no flags Details | Formatted Diff | Diff
Patch (3.66 KB, patch)
2018-04-16 08:01 PDT, Eric Stobbart
no flags Details | Formatted Diff | Diff
Patch (4.19 KB, patch)
2018-04-16 08:11 PDT, Eric Stobbart
no flags Details | Formatted Diff | Diff
Archive of layout-test-results from ews123 for ios-simulator-wk2 (8.84 MB, application/zip)
2018-04-16 09:44 PDT, Build Bot
no flags Details
Patch (3.62 KB, patch)
2018-04-17 20:10 PDT, Eric Stobbart
no flags Details | Formatted Diff | Diff
Archive of layout-test-results from ews206 for win-future (12.62 MB, application/zip)
2018-04-17 22:39 PDT, Build Bot
no flags Details
Patch (3.63 KB, patch)
2018-04-18 18:42 PDT, Eric Stobbart
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Eric Stobbart 2018-04-15 22:03:27 PDT
MediaSource.idl is using a cached wrapped object, causing SourceBuffers to leak.
Comment 1 Eric Stobbart 2018-04-15 22:05:15 PDT
Created attachment 337987 [details]
Patch
Comment 2 Eric Stobbart 2018-04-16 06:34:55 PDT
Created attachment 337995 [details]
Patch
Comment 3 Eric Stobbart 2018-04-16 08:01:49 PDT
Created attachment 337999 [details]
Patch
Comment 4 Eric Stobbart 2018-04-16 08:11:17 PDT
Created attachment 338003 [details]
Patch
Comment 5 Build Bot 2018-04-16 09:44:01 PDT
Comment on attachment 338003 [details]
Patch

Attachment 338003 [details] did not pass ios-sim-ews (ios-simulator-wk2):
Output: http://webkit-queues.webkit.org/results/7331662

New failing tests:
compositing/debug-borders-dynamic.html
Comment 6 Build Bot 2018-04-16 09:44:03 PDT
Created attachment 338008 [details]
Archive of layout-test-results from ews123 for ios-simulator-wk2

The attached test failures were seen while running run-webkit-tests on the ios-sim-ews.
Bot: ews123  Port: ios-simulator-wk2  Platform: Mac OS X 10.13.4
Comment 7 Eric Stobbart 2018-04-17 20:09:02 PDT
Original description isn't as accurate as it should be.
Edited the title to better reflect the issue.
Comment 8 Eric Stobbart 2018-04-17 20:10:08 PDT
Created attachment 338192 [details]
Patch
Comment 9 Eric Stobbart 2018-04-17 21:01:24 PDT
I'm unable to reproduce these build failures locally.
Could someone help me look into this?
Comment 10 Build Bot 2018-04-17 22:39:40 PDT
Comment on attachment 338192 [details]
Patch

Attachment 338192 [details] did not pass win-ews (win):
Output: http://webkit-queues.webkit.org/results/7353004

New failing tests:
http/tests/security/contentSecurityPolicy/video-with-https-url-allowed-by-csp-media-src-star.html
Comment 11 Build Bot 2018-04-17 22:39:51 PDT
Created attachment 338196 [details]
Archive of layout-test-results from ews206 for win-future

The attached test failures were seen while running run-webkit-tests on the win-ews.
Bot: ews206  Port: win-future  Platform: CYGWIN_NT-6.1-2.9.0-0.318-5-3-x86_64-64bit
Comment 12 Chris Dumez 2018-04-18 14:29:27 PDT
Comment on attachment 338192 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=338192&action=review

> Source/WebCore/Modules/mediasource/MediaSource.cpp:677
> +    return buffer;

return WTFMove(buffer); I think
Comment 13 Eric Stobbart 2018-04-18 18:42:41 PDT
Created attachment 338295 [details]
Patch
Comment 14 Eric Stobbart 2018-04-19 06:43:35 PDT
(In reply to Chris Dumez from comment #12)
> Comment on attachment 338192 [details]
> Patch
> 
> View in context:
> https://bugs.webkit.org/attachment.cgi?id=338192&action=review
> 
> > Source/WebCore/Modules/mediasource/MediaSource.cpp:677
> > +    return buffer;
> 
> return WTFMove(buffer); I think

Magic. Thanks man!
Comment 15 Chris Dumez 2018-04-19 08:35:07 PDT
Comment on attachment 338295 [details]
Patch

r=me
Comment 16 WebKit Commit Bot 2018-04-19 09:01:15 PDT
Comment on attachment 338295 [details]
Patch

Clearing flags on attachment: 338295

Committed r230805: <https://trac.webkit.org/changeset/230805>
Comment 17 WebKit Commit Bot 2018-04-19 09:01:17 PDT
All reviewed patches have been landed.  Closing bug.
Comment 18 Radar WebKit Bug Importer 2018-04-19 09:04:34 PDT
<rdar://problem/39565703>