Bug 18458 - very high processor and disk usage on wmv clips
Summary: very high processor and disk usage on wmv clips
Status: RESOLVED WORKSFORME
Alias: None
Product: WebKit
Classification: Unclassified
Component: Plug-ins (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh OS X 10.5
: P2 Normal
Assignee: Nobody
URL: http://ru.fishki.net/picsw/042008/11/...
Keywords: InRadar, Performance
: 18457 (view as bug list)
Depends on:
Blocks:
 
Reported: 2008-04-13 04:40 PDT by mntek
Modified: 2008-10-02 07:06 PDT (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description mntek 2008-04-13 04:40:26 PDT
very high processor and disk usage while opening this clip, and after close tab with it.
only restart helps
Comment 1 J. Charles Holt 2008-04-13 08:06:19 PDT
I'm using Flip4Mac, and attempting to play a WMV file spikes the processor usage to maximum, causing my MacBook to get scorching hot.
Comment 2 Alexey Proskuryakov 2008-04-14 00:42:29 PDT
This sounds mostly like a Flip4Mac issue - but it the fact that processor usage stays high after closing the tab might indicate a WebKit plug-in handling problem, too.

I don't have Flip4Mac installed, so I haven't tried to reproduce.
Comment 3 Alexey Proskuryakov 2008-04-14 00:43:42 PDT
<rdar://problem/5861206>
Comment 4 Alexey Proskuryakov 2008-04-14 01:02:13 PDT
*** Bug 18457 has been marked as a duplicate of this bug. ***
Comment 5 Deirdre Saoirse Moen 2008-04-14 16:01:56 PDT
What version(s) of Flip4Mac?
Comment 6 mntek 2008-04-15 00:21:28 PDT
(In reply to comment #5)
> What version(s) of Flip4Mac?
> 

2.2.0.49
Comment 7 Alexey Proskuryakov 2008-05-30 14:56:53 PDT
Could you please attach a sample of Safari after closing the tab? To take the sample, you can use /Applications/Utilities/Activity Monitor.app.
Comment 8 Alexey Proskuryakov 2008-10-02 07:06:18 PDT
I cannot reproduce this issue with Flip4Mac 2.2.1.11. When the video from bug URL is playing, Safari processor usage of my PowerMac G4/1.25 is under 25%. When I close the tab, it immediately drops to zero.

Tested with shipping Safari/WebKit 3.1.2 and with a local WebKit build under Mac OS X 10.4.11.

Closing as WORKSFORME, please re-open if you are still seeing this issue with latest Flip4Mac.