Bug 184531 - [GLIB] Tests WTF_RefPtr.ReleaseInNonMainThread and WTF_RefPtr.ReleaseInNonMainThreadDestroyInMainThread are crashing since they were added
Summary: [GLIB] Tests WTF_RefPtr.ReleaseInNonMainThread and WTF_RefPtr.ReleaseInNonMai...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords: Gtk, InRadar
Depends on:
Blocks:
 
Reported: 2018-04-12 03:16 PDT by Carlos Garcia Campos
Modified: 2018-04-13 00:29 PDT (History)
5 users (show)

See Also:


Attachments
Patch (2.83 KB, patch)
2018-04-12 03:41 PDT, Carlos Garcia Campos
mcatanzaro: review+
ews: commit-queue-
Details | Formatted Diff | Diff
Archive of layout-test-results from ews200 for win-future (12.77 MB, application/zip)
2018-04-12 07:16 PDT, Build Bot
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Carlos Garcia Campos 2018-04-12 03:16:05 PDT
It's not a bug in WebKit, but in the GLib implementation of TestWebKitAPI::Util::run(). We try to quit the main loop that hasn't been initialized. We should always use RunLoop::current() instead.
Comment 1 Carlos Garcia Campos 2018-04-12 03:28:55 PDT
hmm, fixing Uril::run() works for ReleaseInNonMainThread, but not for ReleaseInNonMainThreadDestroyInMainThread, because it ends up using scheduleOnMainThread and the generic implementation of that used RunLoop::main() too, so we need to initialize the main loop in that test.
Comment 2 Carlos Garcia Campos 2018-04-12 03:41:38 PDT
Created attachment 337786 [details]
Patch
Comment 3 Build Bot 2018-04-12 07:16:07 PDT
Comment on attachment 337786 [details]
Patch

Attachment 337786 [details] did not pass win-ews (win):
Output: http://webkit-queues.webkit.org/results/7293838

New failing tests:
http/tests/security/contentSecurityPolicy/userAgentShadowDOM/allow-audio.html
Comment 4 Build Bot 2018-04-12 07:16:18 PDT
Created attachment 337795 [details]
Archive of layout-test-results from ews200 for win-future

The attached test failures were seen while running run-webkit-tests on the win-ews.
Bot: ews200  Port: win-future  Platform: CYGWIN_NT-6.1-2.9.0-0.318-5-3-x86_64-64bit
Comment 5 Carlos Garcia Campos 2018-04-13 00:27:10 PDT
Committed r230624: <https://trac.webkit.org/changeset/230624>
Comment 6 Radar WebKit Bug Importer 2018-04-13 00:29:17 PDT
<rdar://problem/39406337>