Bug 184105 - Resync web-platform-tests up to 42f43956d49feb44ac03a0945a64066dd77e1f6c
Summary: Resync web-platform-tests up to 42f43956d49feb44ac03a0945a64066dd77e1f6c
Status: RESOLVED MOVED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-03-28 12:12 PDT by Brendan McLoughlin
Modified: 2018-04-03 13:35 PDT (History)
4 users (show)

See Also:


Attachments
Patch (516.19 KB, patch)
2018-03-28 12:12 PDT, Brendan McLoughlin
no flags Details | Formatted Diff | Diff
Archive of layout-test-results from ews101 for mac-sierra (2.37 MB, application/zip)
2018-03-28 13:02 PDT, Build Bot
no flags Details
Archive of layout-test-results from ews107 for mac-sierra-wk2 (3.04 MB, application/zip)
2018-03-28 13:08 PDT, Build Bot
no flags Details
Archive of layout-test-results from ews126 for ios-simulator-wk2 (2.18 MB, application/zip)
2018-03-28 13:48 PDT, Build Bot
no flags Details
Archive of layout-test-results from ews115 for mac-sierra (3.15 MB, application/zip)
2018-03-28 13:49 PDT, Build Bot
no flags Details
Patch (519.93 KB, patch)
2018-03-29 11:24 PDT, Brendan McLoughlin
no flags Details | Formatted Diff | Diff
Patch (117.29 KB, patch)
2018-03-29 11:49 PDT, Brendan McLoughlin
no flags Details | Formatted Diff | Diff
Archive of layout-test-results from ews100 for mac-sierra (2.26 MB, application/zip)
2018-03-29 12:53 PDT, Build Bot
no flags Details
Archive of layout-test-results from ews105 for mac-sierra-wk2 (2.74 MB, application/zip)
2018-03-29 12:59 PDT, Build Bot
no flags Details
Archive of layout-test-results from ews117 for mac-sierra (3.12 MB, application/zip)
2018-03-29 13:26 PDT, Build Bot
no flags Details
Archive of layout-test-results from ews123 for ios-simulator-wk2 (2.17 MB, application/zip)
2018-03-29 13:28 PDT, Build Bot
no flags Details
Patch (509.07 KB, patch)
2018-03-29 14:43 PDT, Brendan McLoughlin
no flags Details | Formatted Diff | Diff
Archive of layout-test-results from ews103 for mac-sierra (2.22 MB, application/zip)
2018-03-29 15:51 PDT, Build Bot
no flags Details
Archive of layout-test-results from ews113 for mac-sierra (3.12 MB, application/zip)
2018-03-29 16:24 PDT, Build Bot
no flags Details
Patch (574.07 KB, patch)
2018-03-30 08:07 PDT, Brendan McLoughlin
no flags Details | Formatted Diff | Diff
Archive of layout-test-results from ews100 for mac-sierra (2.36 MB, application/zip)
2018-03-30 09:15 PDT, Build Bot
no flags Details
Archive of layout-test-results from ews105 for mac-sierra-wk2 (2.80 MB, application/zip)
2018-03-30 09:19 PDT, Build Bot
no flags Details
Archive of layout-test-results from ews123 for ios-simulator-wk2 (2.37 MB, application/zip)
2018-03-30 09:50 PDT, Build Bot
no flags Details
Archive of layout-test-results from ews113 for mac-sierra (3.26 MB, application/zip)
2018-03-30 09:51 PDT, Build Bot
no flags Details
Patch (3.08 MB, patch)
2018-03-30 14:42 PDT, Brendan McLoughlin
no flags Details | Formatted Diff | Diff
Patch (8.33 MB, patch)
2018-04-03 11:22 PDT, Brendan McLoughlin
brendan: review?
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Brendan McLoughlin 2018-03-28 12:12:18 PDT
Resync web-platform-tests up to 42f43956d49feb44ac03a0945a64066dd77e1f6c
Comment 1 Brendan McLoughlin 2018-03-28 12:12:54 PDT
Created attachment 336691 [details]
Patch
Comment 2 Build Bot 2018-03-28 13:02:51 PDT
Comment on attachment 336691 [details]
Patch

Attachment 336691 [details] did not pass mac-ews (mac):
Output: http://webkit-queues.webkit.org/results/7127200

New failing tests:
imported/w3c/web-platform-tests/fetch/api/request/destination/fetch-destination-iframe.https.html
imported/w3c/web-platform-tests/fetch/corb/img-png-mislabeled-as-html-nosniff.tentative.sub.html
imported/w3c/web-platform-tests/fetch/corb/img-html-correctly-labeled.sub.html
imported/w3c/web-platform-tests/fetch/corb/img-png-mislabeled-as-html.sub.html
imported/w3c/web-platform-tests/fetch/api/request/destination/fetch-destination-no-load-event.https.html
imported/w3c/web-platform-tests/fetch/api/response/response-error-from-stream.html
imported/w3c/web-platform-tests/fetch/api/request/destination/fetch-destination.https.html
imported/w3c/web-platform-tests/fetch/api/request/destination/fetch-destination-worker.https.html
Comment 3 Build Bot 2018-03-28 13:02:53 PDT
Created attachment 336703 [details]
Archive of layout-test-results from ews101 for mac-sierra

The attached test failures were seen while running run-webkit-tests on the mac-ews.
Bot: ews101  Port: mac-sierra  Platform: Mac OS X 10.12.6
Comment 4 Build Bot 2018-03-28 13:08:52 PDT
Comment on attachment 336691 [details]
Patch

Attachment 336691 [details] did not pass mac-wk2-ews (mac-wk2):
Output: http://webkit-queues.webkit.org/results/7127264

New failing tests:
imported/w3c/web-platform-tests/fetch/corb/img-png-mislabeled-as-html.sub.html
imported/w3c/web-platform-tests/fetch/corb/img-png-mislabeled-as-html-nosniff.tentative.sub.html
imported/w3c/web-platform-tests/fetch/corb/img-html-correctly-labeled.sub.html
Comment 5 Build Bot 2018-03-28 13:08:54 PDT
Created attachment 336707 [details]
Archive of layout-test-results from ews107 for mac-sierra-wk2

The attached test failures were seen while running run-webkit-tests on the mac-wk2-ews.
Bot: ews107  Port: mac-sierra-wk2  Platform: Mac OS X 10.12.6
Comment 6 Build Bot 2018-03-28 13:48:53 PDT
Comment on attachment 336691 [details]
Patch

Attachment 336691 [details] did not pass ios-sim-ews (ios-simulator-wk2):
Output: http://webkit-queues.webkit.org/results/7127711

New failing tests:
imported/w3c/web-platform-tests/fetch/corb/img-png-mislabeled-as-html.sub.html
imported/w3c/web-platform-tests/fetch/corb/img-png-mislabeled-as-html-nosniff.tentative.sub.html
imported/w3c/web-platform-tests/fetch/corb/img-html-correctly-labeled.sub.html
Comment 7 Build Bot 2018-03-28 13:48:54 PDT
Created attachment 336712 [details]
Archive of layout-test-results from ews126 for ios-simulator-wk2

The attached test failures were seen while running run-webkit-tests on the ios-sim-ews.
Bot: ews126  Port: ios-simulator-wk2  Platform: Mac OS X 10.12.6
Comment 8 Build Bot 2018-03-28 13:49:44 PDT
Comment on attachment 336691 [details]
Patch

Attachment 336691 [details] did not pass mac-debug-ews (mac):
Output: http://webkit-queues.webkit.org/results/7127762

New failing tests:
imported/w3c/web-platform-tests/fetch/api/request/destination/fetch-destination-iframe.https.html
imported/w3c/web-platform-tests/fetch/api/redirect/redirect-method.html
imported/w3c/web-platform-tests/fetch/api/request/destination/fetch-destination.https.html
imported/w3c/web-platform-tests/fetch/corb/img-html-correctly-labeled.sub.html
imported/w3c/web-platform-tests/fetch/corb/img-png-mislabeled-as-html.sub.html
imported/w3c/web-platform-tests/fetch/api/request/destination/fetch-destination-no-load-event.https.html
imported/w3c/web-platform-tests/fetch/corb/img-png-mislabeled-as-html-nosniff.tentative.sub.html
imported/w3c/web-platform-tests/fetch/api/redirect/redirect-method-worker.html
imported/w3c/web-platform-tests/fetch/api/request/destination/fetch-destination-worker.https.html
Comment 9 Build Bot 2018-03-28 13:49:45 PDT
Created attachment 336713 [details]
Archive of layout-test-results from ews115 for mac-sierra

The attached test failures were seen while running run-webkit-tests on the mac-debug-ews.
Bot: ews115  Port: mac-sierra  Platform: Mac OS X 10.12.6
Comment 10 Brendan McLoughlin 2018-03-29 11:24:38 PDT
Created attachment 336787 [details]
Patch
Comment 11 Brendan McLoughlin 2018-03-29 11:49:15 PDT
Created attachment 336791 [details]
Patch
Comment 12 Build Bot 2018-03-29 11:52:27 PDT
Attachment 336791 [details] did not pass style-queue:


ERROR: LayoutTests/TestExpectations:1783:  Path does not exist.  [test/expectations] [5]
ERROR: LayoutTests/TestExpectations:1784:  Path does not exist.  [test/expectations] [5]
ERROR: LayoutTests/TestExpectations:1785:  Path does not exist.  [test/expectations] [5]
ERROR: /Volumes/Data/StyleQueue/WebKit/LayoutTests/TestExpectations:1783:  Path does not exist.  [test/expectations] [5]
ERROR: /Volumes/Data/StyleQueue/WebKit/LayoutTests/TestExpectations:1784:  Path does not exist.  [test/expectations] [5]
ERROR: /Volumes/Data/StyleQueue/WebKit/LayoutTests/TestExpectations:1785:  Path does not exist.  [test/expectations] [5]
Total errors found: 6 in 64 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 13 Build Bot 2018-03-29 12:53:48 PDT
Comment on attachment 336791 [details]
Patch

Attachment 336791 [details] did not pass mac-ews (mac):
Output: http://webkit-queues.webkit.org/results/7139267

New failing tests:
imported/w3c/web-platform-tests/fetch/http-cache/partial.html
Comment 14 Build Bot 2018-03-29 12:53:49 PDT
Created attachment 336794 [details]
Archive of layout-test-results from ews100 for mac-sierra

The attached test failures were seen while running run-webkit-tests on the mac-ews.
Bot: ews100  Port: mac-sierra  Platform: Mac OS X 10.12.6
Comment 15 Build Bot 2018-03-29 12:59:08 PDT
Comment on attachment 336791 [details]
Patch

Attachment 336791 [details] did not pass mac-wk2-ews (mac-wk2):
Output: http://webkit-queues.webkit.org/results/7139274

New failing tests:
imported/w3c/web-platform-tests/fetch/api/policies/referrer-origin-when-cross-origin-service-worker.https.html
Comment 16 Build Bot 2018-03-29 12:59:09 PDT
Created attachment 336795 [details]
Archive of layout-test-results from ews105 for mac-sierra-wk2

The attached test failures were seen while running run-webkit-tests on the mac-wk2-ews.
Bot: ews105  Port: mac-sierra-wk2  Platform: Mac OS X 10.12.6
Comment 17 Build Bot 2018-03-29 13:25:59 PDT
Comment on attachment 336791 [details]
Patch

Attachment 336791 [details] did not pass mac-debug-ews (mac):
Output: http://webkit-queues.webkit.org/results/7139305

New failing tests:
imported/w3c/web-platform-tests/fetch/api/redirect/redirect-method-worker.html
imported/w3c/web-platform-tests/fetch/api/redirect/redirect-method.html
imported/w3c/web-platform-tests/fetch/http-cache/partial.html
Comment 18 Build Bot 2018-03-29 13:26:00 PDT
Created attachment 336798 [details]
Archive of layout-test-results from ews117 for mac-sierra

The attached test failures were seen while running run-webkit-tests on the mac-debug-ews.
Bot: ews117  Port: mac-sierra  Platform: Mac OS X 10.12.6
Comment 19 Build Bot 2018-03-29 13:28:42 PDT
Comment on attachment 336791 [details]
Patch

Attachment 336791 [details] did not pass ios-sim-ews (ios-simulator-wk2):
Output: http://webkit-queues.webkit.org/results/7139313

New failing tests:
imported/w3c/web-platform-tests/fetch/api/policies/referrer-origin-when-cross-origin-service-worker.https.html
Comment 20 Build Bot 2018-03-29 13:28:44 PDT
Created attachment 336800 [details]
Archive of layout-test-results from ews123 for ios-simulator-wk2

The attached test failures were seen while running run-webkit-tests on the ios-sim-ews.
Bot: ews123  Port: ios-simulator-wk2  Platform: Mac OS X 10.12.6
Comment 21 Brendan McLoughlin 2018-03-29 14:43:57 PDT
Created attachment 336806 [details]
Patch
Comment 22 Build Bot 2018-03-29 15:51:01 PDT
Comment on attachment 336806 [details]
Patch

Attachment 336806 [details] did not pass mac-ews (mac):
Output: http://webkit-queues.webkit.org/results/7140956

New failing tests:
imported/w3c/web-platform-tests/fetch/api/request/destination/fetch-destination-iframe.https.html
imported/w3c/web-platform-tests/fetch/api/request/destination/fetch-destination-no-load-event.https.html
imported/w3c/web-platform-tests/fetch/api/request/destination/fetch-destination.https.html
imported/w3c/web-platform-tests/fetch/api/request/destination/fetch-destination-worker.https.html
Comment 23 Build Bot 2018-03-29 15:51:03 PDT
Created attachment 336811 [details]
Archive of layout-test-results from ews103 for mac-sierra

The attached test failures were seen while running run-webkit-tests on the mac-ews.
Bot: ews103  Port: mac-sierra  Platform: Mac OS X 10.12.6
Comment 24 Build Bot 2018-03-29 16:24:05 PDT
Comment on attachment 336806 [details]
Patch

Attachment 336806 [details] did not pass mac-debug-ews (mac):
Output: http://webkit-queues.webkit.org/results/7140976

New failing tests:
imported/w3c/web-platform-tests/fetch/api/request/destination/fetch-destination-iframe.https.html
imported/w3c/web-platform-tests/fetch/api/redirect/redirect-method.html
imported/w3c/web-platform-tests/fetch/api/request/destination/fetch-destination.https.html
imported/w3c/web-platform-tests/fetch/api/request/destination/fetch-destination-no-load-event.https.html
imported/w3c/web-platform-tests/fetch/api/redirect/redirect-method-worker.html
imported/w3c/web-platform-tests/fetch/api/request/destination/fetch-destination-worker.https.html
Comment 25 Build Bot 2018-03-29 16:24:07 PDT
Created attachment 336817 [details]
Archive of layout-test-results from ews113 for mac-sierra

The attached test failures were seen while running run-webkit-tests on the mac-debug-ews.
Bot: ews113  Port: mac-sierra  Platform: Mac OS X 10.12.6
Comment 26 Brendan McLoughlin 2018-03-30 08:07:47 PDT
Created attachment 336855 [details]
Patch
Comment 27 youenn fablet 2018-03-30 08:25:46 PDT
It seems the purpose is to refresh a subset of the tests, right, XHR/fetch subfolders and maybe some others? Maybe this could be stated more precisely in the title.

When doing this kind of full resyncing, I usually do not include new tests.
This is only a matter of taste and it is usually to decrease the size of the patch.

Also I usually update LayoutTests/imported/w3c/resources/TestRepositories revision value so that users doing:
import-w3c-tests web-platform-tests/mytestsuite
will use that specific revision.
Comment 28 Chris Dumez 2018-03-30 08:31:35 PDT
Comment on attachment 336855 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=336855&action=review

> LayoutTests/ChangeLog:3
> +        Resync web-platform-tests up to 42f43956d49feb44ac03a0945a64066dd77e1f6c

You only re-synced fetch tests, which is fine but then please say so in the title.

> LayoutTests/imported/w3c/web-platform-tests/XMLHttpRequest/abort-after-send-expected.txt:2
> +FAIL XMLHttpRequest: abort() after send() assert_equals: expected "abort(0,0,false)" but got "upload.progress(0,0,false)"

Looks like you may have generated those XMLHttpRequest expectations using an old version of WebKit. I fixed those bugs in trunk recently. I do not believe these XHR rebaselines are correct.
Comment 29 Brendan McLoughlin 2018-03-30 08:41:25 PDT
(In reply to Chris Dumez from comment #28)
> Comment on attachment 336855 [details]
> Patch
> 
> View in context:
> https://bugs.webkit.org/attachment.cgi?id=336855&action=review
> 
> > LayoutTests/ChangeLog:3
> > +        Resync web-platform-tests up to 42f43956d49feb44ac03a0945a64066dd77e1f6c
> 
> You only re-synced fetch tests, which is fine but then please say so in the
> title.

I originally pushed up a patch with just the fetch tests to help me understand how the CI handles changes to the web-platform-test. My last patch was intended to have everything but I seem to have messed something up.

> > LayoutTests/imported/w3c/web-platform-tests/XMLHttpRequest/abort-after-send-expected.txt:2
> > +FAIL XMLHttpRequest: abort() after send() assert_equals: expected "abort(0,0,false)" but got "upload.progress(0,0,false)"
> 
> Looks like you may have generated those XMLHttpRequest expectations using an
> old version of WebKit. I fixed those bugs in trunk recently. I do not
> believe these XHR rebaselines are correct.

I will re-sync to the latest head of webkit and try these expectations again.
Comment 30 Brendan McLoughlin 2018-03-30 08:43:23 PDT
(In reply to youenn fablet from comment #27)

> When doing this kind of full resyncing, I usually do not include new tests.
> This is only a matter of taste and it is usually to decrease the size of the
> patch.

I will do that. Do you usually follow up with a second patch to add the new tests?

> Also I usually update LayoutTests/imported/w3c/resources/TestRepositories
> revision value so that users doing:
> import-w3c-tests web-platform-tests/mytestsuite
> will use that specific revision.

Will do.
Comment 31 Build Bot 2018-03-30 09:15:04 PDT
Comment on attachment 336855 [details]
Patch

Attachment 336855 [details] did not pass mac-ews (mac):
Output: http://webkit-queues.webkit.org/results/7148046

New failing tests:
imported/w3c/web-platform-tests/fetch/api/request/destination/fetch-destination-iframe.https.html
imported/w3c/web-platform-tests/XMLHttpRequest/abort-event-abort.htm
imported/w3c/web-platform-tests/XMLHttpRequest/send-network-error-async-events.sub.htm
imported/w3c/web-platform-tests/fetch/api/request/destination/fetch-destination.https.html
imported/w3c/web-platform-tests/XMLHttpRequest/open-send-during-abort.htm
imported/w3c/web-platform-tests/XMLHttpRequest/send-data-unexpected-tostring.htm
imported/w3c/web-platform-tests/XMLHttpRequest/open-during-abort.htm
imported/w3c/web-platform-tests/XMLHttpRequest/open-during-abort-processing.htm
imported/w3c/web-platform-tests/XMLHttpRequest/abort-after-send.htm
imported/w3c/web-platform-tests/XMLHttpRequest/security-consideration.sub.html
imported/w3c/web-platform-tests/XMLHttpRequest/abort-event-order.htm
imported/w3c/web-platform-tests/fetch/api/request/destination/fetch-destination-no-load-event.https.html
imported/w3c/web-platform-tests/fetch/api/response/response-error-from-stream.html
imported/w3c/web-platform-tests/XMLHttpRequest/open-during-abort-event.htm
imported/w3c/web-platform-tests/fetch/api/request/destination/fetch-destination-worker.https.html
imported/w3c/web-platform-tests/XMLHttpRequest/send-authentication-basic-cors.htm
imported/w3c/web-platform-tests/XMLHttpRequest/abort-during-open.worker.html
imported/w3c/web-platform-tests/XMLHttpRequest/abort-during-open.htm
imported/w3c/web-platform-tests/cors/late-upload-events.htm
imported/w3c/web-platform-tests/web-animations/animation-model/keyframe-effects/effect-value-iteration-composite-operation.html
Comment 32 Build Bot 2018-03-30 09:15:06 PDT
Created attachment 336858 [details]
Archive of layout-test-results from ews100 for mac-sierra

The attached test failures were seen while running run-webkit-tests on the mac-ews.
Bot: ews100  Port: mac-sierra  Platform: Mac OS X 10.12.6
Comment 33 Build Bot 2018-03-30 09:19:41 PDT
Comment on attachment 336855 [details]
Patch

Attachment 336855 [details] did not pass mac-wk2-ews (mac-wk2):
Output: http://webkit-queues.webkit.org/results/7148085

New failing tests:
imported/w3c/web-platform-tests/XMLHttpRequest/send-network-error-async-events.sub.htm
imported/w3c/web-platform-tests/XMLHttpRequest/open-send-during-abort.htm
imported/w3c/web-platform-tests/XMLHttpRequest/open-during-abort.htm
imported/w3c/web-platform-tests/XMLHttpRequest/open-during-abort-processing.htm
imported/w3c/web-platform-tests/XMLHttpRequest/abort-after-send.htm
imported/w3c/web-platform-tests/XMLHttpRequest/abort-event-order.htm
imported/w3c/web-platform-tests/XMLHttpRequest/abort-event-abort.htm
imported/w3c/web-platform-tests/html/browsers/the-window-object/apis-for-creating-and-navigating-browsing-contexts-by-name/open-features-non-integer-screeny.html
imported/w3c/web-platform-tests/XMLHttpRequest/open-during-abort-event.htm
imported/w3c/web-platform-tests/cors/late-upload-events.htm
imported/w3c/web-platform-tests/XMLHttpRequest/send-authentication-basic-cors.htm
imported/w3c/web-platform-tests/XMLHttpRequest/abort-during-open.worker.html
imported/w3c/web-platform-tests/web-animations/animation-model/keyframe-effects/effect-value-iteration-composite-operation.html
imported/w3c/web-platform-tests/XMLHttpRequest/abort-during-open.htm
imported/w3c/web-platform-tests/XMLHttpRequest/send-data-unexpected-tostring.htm
imported/w3c/web-platform-tests/XMLHttpRequest/security-consideration.sub.html
Comment 34 Build Bot 2018-03-30 09:19:42 PDT
Created attachment 336859 [details]
Archive of layout-test-results from ews105 for mac-sierra-wk2

The attached test failures were seen while running run-webkit-tests on the mac-wk2-ews.
Bot: ews105  Port: mac-sierra-wk2  Platform: Mac OS X 10.12.6
Comment 35 Build Bot 2018-03-30 09:50:39 PDT
Comment on attachment 336855 [details]
Patch

Attachment 336855 [details] did not pass ios-sim-ews (ios-simulator-wk2):
Output: http://webkit-queues.webkit.org/results/7148165

New failing tests:
imported/w3c/web-platform-tests/web-animations/animation-model/animation-types/addition-per-property.html
imported/w3c/web-platform-tests/XMLHttpRequest/send-network-error-async-events.sub.htm
imported/w3c/web-platform-tests/XMLHttpRequest/open-send-during-abort.htm
imported/w3c/web-platform-tests/XMLHttpRequest/open-during-abort.htm
imported/w3c/web-platform-tests/XMLHttpRequest/open-during-abort-processing.htm
imported/w3c/web-platform-tests/web-animations/animation-model/animation-types/interpolation-per-property.html
imported/w3c/web-platform-tests/XMLHttpRequest/abort-after-send.htm
imported/w3c/web-platform-tests/XMLHttpRequest/abort-event-order.htm
imported/w3c/web-platform-tests/XMLHttpRequest/abort-event-abort.htm
imported/w3c/web-platform-tests/fetch/api/response/response-error-from-stream.html
imported/w3c/web-platform-tests/XMLHttpRequest/open-during-abort-event.htm
imported/w3c/web-platform-tests/cors/late-upload-events.htm
imported/w3c/web-platform-tests/XMLHttpRequest/send-authentication-basic-cors.htm
imported/w3c/web-platform-tests/web-animations/animation-model/keyframe-effects/effect-value-iteration-composite-operation.html
imported/w3c/web-platform-tests/XMLHttpRequest/abort-during-open.worker.html
imported/w3c/web-platform-tests/web-animations/animation-model/animation-types/accumulation-per-property.html
imported/w3c/web-platform-tests/XMLHttpRequest/abort-during-open.htm
imported/w3c/web-platform-tests/XMLHttpRequest/send-data-unexpected-tostring.htm
imported/w3c/web-platform-tests/XMLHttpRequest/security-consideration.sub.html
Comment 36 Build Bot 2018-03-30 09:50:40 PDT
Created attachment 336862 [details]
Archive of layout-test-results from ews123 for ios-simulator-wk2

The attached test failures were seen while running run-webkit-tests on the ios-sim-ews.
Bot: ews123  Port: ios-simulator-wk2  Platform: Mac OS X 10.12.6
Comment 37 Build Bot 2018-03-30 09:51:01 PDT
Comment on attachment 336855 [details]
Patch

Attachment 336855 [details] did not pass mac-debug-ews (mac):
Output: http://webkit-queues.webkit.org/results/7148150

New failing tests:
imported/w3c/web-platform-tests/fetch/api/request/destination/fetch-destination-iframe.https.html
imported/w3c/web-platform-tests/fetch/api/request/destination/fetch-destination-no-load-event.https.html
imported/w3c/web-platform-tests/XMLHttpRequest/send-network-error-async-events.sub.htm
imported/w3c/web-platform-tests/fetch/api/request/destination/fetch-destination.https.html
imported/w3c/web-platform-tests/XMLHttpRequest/open-send-during-abort.htm
imported/w3c/web-platform-tests/XMLHttpRequest/open-during-abort.htm
imported/w3c/web-platform-tests/XMLHttpRequest/open-during-abort-processing.htm
imported/w3c/web-platform-tests/XMLHttpRequest/abort-after-send.htm
imported/w3c/web-platform-tests/XMLHttpRequest/abort-event-order.htm
imported/w3c/web-platform-tests/cors/late-upload-events.htm
imported/w3c/web-platform-tests/XMLHttpRequest/abort-event-abort.htm
imported/w3c/web-platform-tests/XMLHttpRequest/open-during-abort-event.htm
imported/w3c/web-platform-tests/fetch/api/redirect/redirect-method.html
imported/w3c/web-platform-tests/fetch/api/request/destination/fetch-destination-worker.https.html
imported/w3c/web-platform-tests/XMLHttpRequest/send-authentication-basic-cors.htm
imported/w3c/web-platform-tests/fetch/api/redirect/redirect-method-worker.html
imported/w3c/web-platform-tests/XMLHttpRequest/abort-during-open.worker.html
imported/w3c/web-platform-tests/web-animations/animation-model/keyframe-effects/effect-value-iteration-composite-operation.html
imported/w3c/web-platform-tests/XMLHttpRequest/abort-during-open.htm
imported/w3c/web-platform-tests/XMLHttpRequest/send-data-unexpected-tostring.htm
imported/w3c/web-platform-tests/XMLHttpRequest/security-consideration.sub.html
Comment 38 Build Bot 2018-03-30 09:51:02 PDT
Created attachment 336863 [details]
Archive of layout-test-results from ews113 for mac-sierra

The attached test failures were seen while running run-webkit-tests on the mac-debug-ews.
Bot: ews113  Port: mac-sierra  Platform: Mac OS X 10.12.6
Comment 39 Brendan McLoughlin 2018-03-30 14:42:53 PDT
Created attachment 336887 [details]
Patch
Comment 40 Brendan McLoughlin 2018-04-03 11:22:19 PDT
Created attachment 337096 [details]
Patch
Comment 41 Brendan McLoughlin 2018-04-03 13:35:43 PDT
youenn suggested I split this into smaller patches to make it easier to land without conflicts. The first patch is opened as https://bugs.webkit.org/show_bug.cgi?id=184278 . I tried to update this issue with that change but I kept getting network errors when attempting to obsolete the old patch. I'm going to close this issue.