Bug 183885 - Regression(r229831): fast/loader/javascript-url-iframe-remove-on-navigate-async-delegate.html is flaky
Summary: Regression(r229831): fast/loader/javascript-url-iframe-remove-on-navigate-asy...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Chris Dumez
URL:
Keywords: InRadar
Depends on:
Blocks: 180568
  Show dependency treegraph
 
Reported: 2018-03-21 18:43 PDT by Chris Dumez
Modified: 2018-05-23 21:08 PDT (History)
6 users (show)

See Also:


Attachments
Patch (4.46 KB, patch)
2018-05-23 15:42 PDT, Chris Dumez
no flags Details | Formatted Diff | Diff
Archive of layout-test-results from ews204 for win-future (12.74 MB, application/zip)
2018-05-23 19:47 PDT, EWS Watchlist
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Dumez 2018-03-21 18:43:21 PDT
Regression(r229831): fast/loader/javascript-url-iframe-remove-on-navigate-async-delegate.html is flaky:
--- /Volumes/Data/slave/sierra-release-tests-wk2/build/layout-test-results/fast/loader/javascript-url-iframe-remove-on-navigate-async-delegate-expected.txt
+++ /Volumes/Data/slave/sierra-release-tests-wk2/build/layout-test-results/fast/loader/javascript-url-iframe-remove-on-navigate-async-delegate-actual.txt
@@ -1,2 +1 @@
-Blocked access to external URL http://does.not.exist/
 PASS - Javascript URL blocked without crashing.
Comment 1 Chris Dumez 2018-03-21 18:47:48 PDT
Committed r229840: <https://trac.webkit.org/changeset/229840>
Comment 2 Chris Dumez 2018-03-21 18:48:31 PDT
Reopening since I merely marked the test as flaky for now. Will investigate tomorrow.
Comment 3 Radar WebKit Bug Importer 2018-03-21 19:03:10 PDT
<rdar://problem/38733968>
Comment 4 Chris Dumez 2018-03-22 09:39:12 PDT
Does not reproduce with:
Tools/Scripts/run-webkit-tests fast/loader/javascript-url-iframe-remove-on-navigate.html fast/loader/javascript-url-iframe-remove-on-navigate-async-delegate.html --repeat-each=1000 -f
Comment 5 Chris Dumez 2018-05-23 15:42:40 PDT
Created attachment 341137 [details]
Patch
Comment 6 EWS Watchlist 2018-05-23 19:47:40 PDT
Comment on attachment 341137 [details]
Patch

Attachment 341137 [details] did not pass win-ews (win):
Output: http://webkit-queues.webkit.org/results/7783470

New failing tests:
http/tests/security/canvas-remote-read-remote-video-redirect.html
Comment 7 EWS Watchlist 2018-05-23 19:47:51 PDT
Created attachment 341160 [details]
Archive of layout-test-results from ews204 for win-future

The attached test failures were seen while running run-webkit-tests on the win-ews.
Bot: ews204  Port: win-future  Platform: CYGWIN_NT-6.1-2.9.0-0.318-5-3-x86_64-64bit
Comment 8 WebKit Commit Bot 2018-05-23 21:08:48 PDT
Comment on attachment 341137 [details]
Patch

Clearing flags on attachment: 341137

Committed r232144: <https://trac.webkit.org/changeset/232144>
Comment 9 WebKit Commit Bot 2018-05-23 21:08:50 PDT
All reviewed patches have been landed.  Closing bug.