Bug 18385 - REGRESSION: Selection of Kannada font not occurring for all Kannada script characters
Summary: REGRESSION: Selection of Kannada font not occurring for all Kannada script ch...
Status: RESOLVED WORKSFORME
Alias: None
Product: WebKit
Classification: Unclassified
Component: Layout and Rendering (show other bugs)
Version: 525.x (Safari 3.1)
Hardware: Macintosh OS X 10.5
: P2 Major
Assignee: Nobody
URL: http://sampada.net/article/8005
Keywords:
Depends on:
Blocks:
 
Reported: 2008-04-09 07:42 PDT by Nicholas Shanks
Modified: 2009-11-30 17:10 PST (History)
1 user (show)

See Also:


Attachments
Screenshot of page displaying bug (165.21 KB, application/pdf)
2008-04-09 07:45 PDT, Nicholas Shanks
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Nicholas Shanks 2008-04-09 07:42:22 PDT
1) Download and install http://web.nickshanks.com/downloads/fonts/Kedage.dfont
2) Restart Safari
3) Go to a Kannada site such as http://sampada.net/article/8005

Previous behaviour:
All glyphs in the Kannada script would render with the Kedage font.

Current behaviour:
Some glyphs do, and some don't. Haven't done a reduction.
Comment 1 Nicholas Shanks 2008-04-09 07:45:01 PDT
Created attachment 20430 [details]
Screenshot of page displaying bug
Comment 2 Nicholas Shanks 2008-09-25 12:42:43 PDT
I am now on a different machine, and Safari 3.1.2 & r36901 are displaying all glyphs fine. Not sure if bug was fixed or not.
Comment 3 Alexey Proskuryakov 2008-09-26 00:55:03 PDT
I tried downloading the font, but web.nickshanks.com didn't respond. Would it be possible for you to attach the font here?
Comment 4 Nicholas Shanks 2008-09-26 07:54:00 PDT
yeah, i was logged in to my G5 via VNC, installing 10.5.5 earlier this week, and clicked reboot, and it never came back online. I have no idea why and won't find out until i go back to england at the end of november. can't access via ssh, gopher, http or vnc :-(
Comment 5 Alexey Proskuryakov 2009-11-30 17:10:57 PST
I cannot reproduce this with Safari 4.0.4 on Mac OS X 10.5.8.