Bug 183748 - Image tag inside of SVG block not rendering
Summary: Image tag inside of SVG block not rendering
Status: RESOLVED DUPLICATE of bug 153854
Alias: None
Product: WebKit
Classification: Unclassified
Component: SVG (show other bugs)
Version: Safari 11
Hardware: Macintosh macOS 10.13
: P1 Critical
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-03-19 12:55 PDT by zach.silversmith
Modified: 2019-05-06 15:33 PDT (History)
3 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description zach.silversmith 2018-03-19 12:55:07 PDT
The follow SVG does not render in Safari, but renders in all other major browsers:

<svg width=200 height=200 
     xmlns="http://www.w3.org/2000/svg" 
     xmlns:xlink="http://www.w3.org/1999/xlink">       
  <image href="https://mdn.mozillademos.org/files/6457/mdn_logo_only_color.png" height="200" width="200"/>    
</svg>
Comment 1 zach.silversmith 2018-07-22 08:09:09 PDT
Any updates on this?
Comment 2 Dirk Schulze 2018-07-22 13:26:41 PDT
As a workaround use xlink:href instead of href. href w/o namespace is not implemented at the moment.
Comment 3 Said Abou-Hallawa 2019-05-06 15:33:52 PDT
This is already fixed by https://bugs.webkit.org/show_bug.cgi?id=153854.

*** This bug has been marked as a duplicate of bug 153854 ***