Bug 183628 - Finish migration to MathML WPT tests
Summary: Finish migration to MathML WPT tests
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: MathML (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Frédéric Wang (:fredw)
URL:
Keywords: InRadar
: 165392 (view as bug list)
Depends on: 179110
Blocks:
  Show dependency treegraph
 
Reported: 2018-03-14 04:21 PDT by Frédéric Wang (:fredw)
Modified: 2018-03-14 09:19 PDT (History)
6 users (show)

See Also:


Attachments
Patch (WIP) (107.13 KB, patch)
2018-03-14 04:21 PDT, Frédéric Wang (:fredw)
no flags Details | Formatted Diff | Diff
Patch (120.61 KB, patch)
2018-03-14 08:15 PDT, Frédéric Wang (:fredw)
rego: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Frédéric Wang (:fredw) 2018-03-14 04:21:41 PDT
Created attachment 335766 [details]
Patch (WIP)

This is a follow-up of bug 179110

As said in bug 179110 comment 2, some tests were still tweaked mainly because of bug bug 174030. Apparently an acceptable workaround would be to do a setTimeout(... , 0) before checking document.fonts.ready.
Comment 1 Frédéric Wang (:fredw) 2018-03-14 07:29:17 PDT
*** Bug 165392 has been marked as a duplicate of this bug. ***
Comment 2 Frédéric Wang (:fredw) 2018-03-14 08:15:56 PDT
Created attachment 335769 [details]
Patch
Comment 3 Manuel Rego Casasnovas 2018-03-14 08:28:40 PDT
Comment on attachment 335769 [details]
Patch

Nice, r=me
Comment 4 Frédéric Wang (:fredw) 2018-03-14 09:18:07 PDT
Committed r229601: <https://trac.webkit.org/changeset/229601>
Comment 5 Radar WebKit Bug Importer 2018-03-14 09:19:23 PDT
<rdar://problem/38460716>