RESOLVED FIXED 183593
[Nicosia] Add Cairo-specific GraphicsContext operation recorder
https://bugs.webkit.org/show_bug.cgi?id=183593
Summary [Nicosia] Add Cairo-specific GraphicsContext operation recorder
Zan Dobersek
Reported 2018-03-13 06:39:07 PDT
[Nicosia] Add Cairo-specific GraphicsContext operation recorder
Attachments
Patch (49.10 KB, patch)
2018-03-13 06:57 PDT, Zan Dobersek
no flags
Patch for landing (49.26 KB, patch)
2018-03-16 06:49 PDT, Zan Dobersek
no flags
Zan Dobersek
Comment 1 2018-03-13 06:57:04 PDT
EWS Watchlist
Comment 2 2018-03-13 06:58:09 PDT
Attachment 335691 [details] did not pass style-queue: ERROR: Source/WebCore/platform/graphics/nicosia/cairo/NicosiaCairoOperationRecorder.cpp:50: This { should be at the end of the previous line [whitespace/braces] [4] ERROR: Source/WebCore/platform/graphics/nicosia/cairo/NicosiaCairoOperationRecorder.cpp:61: This { should be at the end of the previous line [whitespace/braces] [4] ERROR: Source/WebCore/platform/graphics/nicosia/cairo/NicosiaCairoOperationRecorder.cpp:69: This { should be at the end of the previous line [whitespace/braces] [4] Total errors found: 3 in 5 files If any of these errors are false positives, please file a bug against check-webkit-style.
Carlos Garcia Campos
Comment 3 2018-03-15 01:18:31 PDT
Comment on attachment 335691 [details] Patch View in context: https://bugs.webkit.org/attachment.cgi?id=335691&action=review > Source/WebCore/platform/graphics/nicosia/cairo/NicosiaCairoOperationRecorder.cpp:41 > +PlatformContextCairo& getContext(PaintingOperationReplay& operationReplay) I would rename this to platformContext() we don't use get in WebKit unless using an out parameter for the return value. > Source/WebCore/platform/graphics/nicosia/cairo/NicosiaCairoOperationRecorder.cpp:366 > + UNUSED_PARAM(color); Why don't you omit the name instead? > Source/WebCore/platform/graphics/nicosia/cairo/NicosiaCairoOperationRecorder.cpp:510 > + UNUSED_PARAM(fontSmoothing); Same here. > Source/WebCore/platform/graphics/nicosia/cairo/NicosiaCairoOperationRecorder.cpp:622 > + Cairo::drawLine(getContext(replayer), arg<0>(), arg<1>(), arg<2>(), arg<3>(), > + arg<4>(), arg<5>()); This could be one line
Zan Dobersek
Comment 4 2018-03-16 06:48:39 PDT
Comment on attachment 335691 [details] Patch View in context: https://bugs.webkit.org/attachment.cgi?id=335691&action=review >> Source/WebCore/platform/graphics/nicosia/cairo/NicosiaCairoOperationRecorder.cpp:41 >> +PlatformContextCairo& getContext(PaintingOperationReplay& operationReplay) > > I would rename this to platformContext() we don't use get in WebKit unless using an out parameter for the return value. Somehow this clashes with GraphicsContext::platformContext(). I'll use contextForReplay() instead. >> Source/WebCore/platform/graphics/nicosia/cairo/NicosiaCairoOperationRecorder.cpp:366 >> + UNUSED_PARAM(color); > > Why don't you omit the name instead? Because that then drops information about the purpose of that parameter, and it's more valuable to me to see what parameters are not being used for the given operation.
Zan Dobersek
Comment 5 2018-03-16 06:49:37 PDT
Created attachment 335933 [details] Patch for landing
EWS Watchlist
Comment 6 2018-03-16 06:51:43 PDT
Attachment 335933 [details] did not pass style-queue: ERROR: Source/WebCore/platform/graphics/nicosia/cairo/NicosiaCairoOperationRecorder.cpp:50: This { should be at the end of the previous line [whitespace/braces] [4] ERROR: Source/WebCore/platform/graphics/nicosia/cairo/NicosiaCairoOperationRecorder.cpp:61: This { should be at the end of the previous line [whitespace/braces] [4] ERROR: Source/WebCore/platform/graphics/nicosia/cairo/NicosiaCairoOperationRecorder.cpp:69: This { should be at the end of the previous line [whitespace/braces] [4] Total errors found: 3 in 5 files If any of these errors are false positives, please file a bug against check-webkit-style.
Zan Dobersek
Comment 7 2018-03-16 10:14:15 PDT
Comment on attachment 335933 [details] Patch for landing Clearing flags on attachment: 335933 Committed r229672: <https://trac.webkit.org/changeset/229672>
Zan Dobersek
Comment 8 2018-03-16 10:14:19 PDT
All reviewed patches have been landed. Closing bug.
Radar WebKit Bug Importer
Comment 9 2018-03-16 10:15:25 PDT
Simon Fraser (smfr)
Comment 10 2018-11-03 09:06:05 PDT
Could this share code with Source/WebCore/platform/graphics/displaylists ?
Note You need to log in before you can comment on or make changes to this bug.