Bug 183564 - [GTK] Intel HD Graphics 3000 GPU hangs with WebKitGTK+ 2.1[4|6].x
Summary: [GTK] Intel HD Graphics 3000 GPU hangs with WebKitGTK+ 2.1[4|6].x
Status: RESOLVED DUPLICATE of bug 170347
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKitGTK (show other bugs)
Version: Other
Hardware: Other Windows 10
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-03-12 06:24 PDT by fredo
Modified: 2018-03-12 07:09 PDT (History)
8 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description fredo 2018-03-12 06:24:00 PDT
+++ This bug was initially created as a clone of Bug #170347 +++

(This was reported by “lashdu” in #epiphany @Freenode, thanks!)

Using Epiphany to browse the web causes a GPU hang which brings down
the entire Wayland session, and the user is sent back to GDM. Some
websites seem to trigger the issue more easily, in particular those
with HTML5 videos or lots of heavy image content.

- WebKitGTK+ 2.14.5
- xf86-video.intel 1:2.99.917+767+g7e9e92c8-1

The issue didn't happen with older versions of WebKitGTK+.

A copy from the system log follows. Also, “/sys/class/drm/card0/error”
does *not* contain a GPU crash dump, despite the log saying so.

---

mar 21 17:05:45 localhost kernel: perf: interrupt took too long (2644 > 2500), lowering kernel.perf_event_max_sample_rate to 75600
mar 21 17:03:58 localhost kernel: drm/i915: Resetting chip after gpu hang
mar 21 17:03:58 localhost kernel: [drm] GPU crash dump saved to /sys/class/drm/card0/error
mar 21 17:03:58 localhost kernel: [drm] The gpu crash dump is required to analyze gpu hangs, so please always attach it.
mar 21 17:03:58 localhost kernel: [drm] drm/i915 developers can then reassign to the right component if it's not a kernel issue.
mar 21 17:03:58 localhost kernel: [drm] Please file a _new_ bug report on bugs.freedesktop.org against DRI -> DRM/Intel
mar 21 17:03:58 localhost kernel: [drm] GPU hangs can indicate a bug anywhere in the entire gfx stack, including userspace.
mar 21 17:03:58 localhost kernel: [drm] GPU HANG: ecode 6:0:0x85fffffc, in WebKitWebProces [3381], reason: Hang on render ring, action: reset
mar 21 17:02:20 localhost telepathy-idle[2241]: Exiting
mar 21 16:59:03 localhost epiphany[1879]: xdg_popup_configure: assertion  'impl->transient_for' failed
mar 21 16:59:03 localhost epiphany[1879]: Window 0x96641b0 is a temporary window without parent, application will not be able to position it on screen.
mar 21 16:59:03 localhost epiphany[1879]: Window 0x96641b0 is a temporary window without parent, application will not be able to position it on screen.
mar 21 16:58:37 localhost epiphany[1879]: xdg_popup_configure: assertion 'impl->transient_for' failed
mar 21 16:58:37 localhost epiphany[1879]: Window 0x9384340 is a temporary window without parent, application will not be able to position it on screen.
mar 21 16:58:37 localhost epiphany[1879]: Window 0x9384340 is a temporary window without parent, application will not be able to position it on screen.
mar 21 16:58:36 localhost epiphany[1879]: xdg_popup_configure: assertion 'impl->transient_for' failed
mar 21 16:58:36 localhost epiphany[1879]: Window 0x6f53c80 is a temporary window without parent, application will not be able to position it on screen.
mar 21 16:58:36 localhost epiphany[1879]: Window 0x6f53c80 is a temporary window without parent, application will not be able to position it on screen.
mar 21 16:58:18 localhost epiphany[1879]: xdg_popup_configure: assertion 'impl->transient_for' failed
mar 21 16:58:18 localhost epiphany[1879]: Window 0x9684190 is a temporary window without parent, application will not be able to position it on screen.
mar 21 16:58:18 localhost epiphany[1879]: Window 0x9684190 is a temporary window without parent, application will not be able to position it on screen.
mar 21 16:57:49 localhost epiphany[1879]: xdg_popup_configure: assertion 'impl->transient_for' failed
mar 21 16:57:49 localhost epiphany[1879]: Window 0x9662b10 is a temporary window without parent, application will not be able to position it on screen.
mar 21 16:57:49 localhost epiphany[1879]: Window 0x9662b10 is a temporary window without parent, application will not be able to position it on screen.
mar 21 16:57:44 localhost epiphany[1879]: xdg_popup_configure: assertion 'impl->transient_for' failed
mar 21 16:57:44 localhost epiphany[1879]: Window 0x9684640 is a temporary window without parent, application will not be able to position it on screen.
mar 21 16:57:44 localhost epiphany[1879]: Window 0x9684640 is a temporary window without parent, application will not be able to position it on screen.
mar 21 16:57:36 localhost epiphany[1879]: xdg_popup_configure: assertion 'impl->transient_for' failed
mar 21 16:57:36 localhost epiphany[1879]: Window 0x6b8eb00 is a temporary window without parent, application will not be able to position it on screen.
mar 21 16:57:36 localhost epiphany[1879]: Window 0x6b8eb00 is a temporary window without parent, application will not be able to position it on screen.
Comment 1 Michael Catanzaro 2018-03-12 07:09:14 PDT

*** This bug has been marked as a duplicate of bug 170347 ***