Bug 183549 - REGRESSION(r211643): Dismissing WKActionSheet should not also dismiss its presenting view controller
Summary: REGRESSION(r211643): Dismissing WKActionSheet should not also dismiss its pre...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKit Misc. (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Wenson Hsieh
URL:
Keywords: InRadar
: 187926 (view as bug list)
Depends on:
Blocks:
 
Reported: 2018-03-11 14:41 PDT by Wenson Hsieh
Modified: 2018-07-27 10:27 PDT (History)
8 users (show)

See Also:


Attachments
Patch (26.59 KB, patch)
2018-03-11 15:15 PDT, Wenson Hsieh
no flags Details | Formatted Diff | Diff
Fix macOS builds (26.69 KB, patch)
2018-03-11 15:19 PDT, Wenson Hsieh
no flags Details | Formatted Diff | Diff
Fix open source iOS builds. (27.43 KB, patch)
2018-03-11 15:49 PDT, Wenson Hsieh
no flags Details | Formatted Diff | Diff
Really fix open source iOS builds. (27.50 KB, patch)
2018-03-11 15:58 PDT, Wenson Hsieh
aestes: review+
Details | Formatted Diff | Diff
Patch for landing (27.49 KB, patch)
2018-03-12 11:48 PDT, Wenson Hsieh
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Wenson Hsieh 2018-03-11 14:41:05 PDT
<rdar://problem/34960698>
Comment 1 Wenson Hsieh 2018-03-11 15:15:05 PDT
Created attachment 335547 [details]
Patch
Comment 2 Wenson Hsieh 2018-03-11 15:19:17 PDT
Created attachment 335548 [details]
Fix macOS builds
Comment 3 Wenson Hsieh 2018-03-11 15:49:31 PDT
Created attachment 335552 [details]
Fix open source iOS builds.
Comment 4 Wenson Hsieh 2018-03-11 15:58:20 PDT
Created attachment 335553 [details]
Really fix open source iOS builds.
Comment 5 Andy Estes 2018-03-12 09:32:48 PDT
Comment on attachment 335553 [details]
Really fix open source iOS builds.

View in context: https://bugs.webkit.org/attachment.cgi?id=335553&action=review

> Tools/TestWebKitAPI/ClassMethodSwizzler.mm:27
> +#include "config.h"
> +#include "ClassMethodSwizzler.h"

#import

> Tools/TestWebKitAPI/Tests/ios/ActionSheetTests.mm:26
>  #include "config.h"

#import

> Tools/TestWebKitAPI/ios/TestWKWebViewController.h:26
> +#pragma once

No need for this.

> Tools/TestWebKitAPI/ios/TestWKWebViewController.mm:31
> +#include "config.h"
> +#include "TestWKWebViewController.h"
> +
> +#if PLATFORM(IOS)
> +
> +#include <wtf/BlockPtr.h>

#import
Comment 6 Wenson Hsieh 2018-03-12 09:45:18 PDT
Comment on attachment 335553 [details]
Really fix open source iOS builds.

View in context: https://bugs.webkit.org/attachment.cgi?id=335553&action=review

Thanks for the review!

>> Tools/TestWebKitAPI/ClassMethodSwizzler.mm:27
>> +#include "ClassMethodSwizzler.h"
> 
> #import

Fixed.

>> Tools/TestWebKitAPI/Tests/ios/ActionSheetTests.mm:26
>>  #include "config.h"
> 
> #import

Fixed.

>> Tools/TestWebKitAPI/ios/TestWKWebViewController.h:26
>> +#pragma once
> 
> No need for this.

Removed.

>> Tools/TestWebKitAPI/ios/TestWKWebViewController.mm:31
>> +#include <wtf/BlockPtr.h>
> 
> #import

Fixed.
Comment 7 Wenson Hsieh 2018-03-12 11:48:52 PDT
Created attachment 335614 [details]
Patch for landing
Comment 8 WebKit Commit Bot 2018-03-12 12:25:23 PDT
Comment on attachment 335614 [details]
Patch for landing

Clearing flags on attachment: 335614

Committed r229542: <https://trac.webkit.org/changeset/229542>
Comment 9 Tim Horton 2018-06-05 15:41:06 PDT
*** Bug 185257 has been marked as a duplicate of this bug. ***
Comment 10 Wenson Hsieh 2018-07-27 10:27:05 PDT
*** Bug 187926 has been marked as a duplicate of this bug. ***