Bug 18330 - REGRESSION: <br> stops clearing float on <select> click
Summary: REGRESSION: <br> stops clearing float on <select> click
Status: RESOLVED DUPLICATE of bug 18172
Alias: None
Product: WebKit
Classification: Unclassified
Component: Layout and Rendering (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh OS X 10.5
: P1 Normal
Assignee: Nobody
URL: http://www.redhot-worldbuffet.com/nor...
Keywords: HasReduction
Depends on:
Blocks:
 
Reported: 2008-04-06 03:59 PDT by Tom Gilder
Modified: 2008-04-08 16:27 PDT (History)
3 users (show)

See Also:


Attachments
Reduction testcase (441 bytes, text/html)
2008-04-06 03:59 PDT, Tom Gilder
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tom Gilder 2008-04-06 03:59:11 PDT
With a combination of floats and form elements, clicking a <select> causes the layout to reflow incorrectly. 

(Annoying music on URL.)
Comment 1 Tom Gilder 2008-04-06 03:59:59 PDT
Created attachment 20362 [details]
Reduction testcase
Comment 2 Tom Gilder 2008-04-07 07:39:10 PDT
This seems to be caused by the <br> no longer respecting clear:left when the <select> is clicked.

Doesn't appear to happen if you replace the <br> with another element.
Comment 3 Eric Seidel (no email) 2008-04-07 08:36:24 PDT
This is a regression since Safari 3.1 (only occurs in the nighly builds).  Wow.  A strange one.
Comment 4 mitz 2008-04-07 08:50:35 PDT
Sounds like bug 18172.
Comment 5 Tom Gilder 2008-04-08 16:27:25 PDT
Fixed with the commit of bug 18172, this was the same issue. Thanks!

*** This bug has been marked as a duplicate of 18172 ***