Bug 183249 - Move resource load statistics tests from js-test-pre.js to js-test.js
Summary: Move resource load statistics tests from js-test-pre.js to js-test.js
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: John Wilander
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2018-03-01 10:59 PST by John Wilander
Modified: 2018-03-01 15:22 PST (History)
4 users (show)

See Also:


Attachments
Patch (30.10 KB, patch)
2018-03-01 11:11 PST, John Wilander
no flags Details | Formatted Diff | Diff
Archive of layout-test-results from ews121 for ios-simulator-wk2 (2.15 MB, application/zip)
2018-03-01 12:41 PST, Build Bot
no flags Details
Patch (31.55 KB, patch)
2018-03-01 13:16 PST, John Wilander
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description John Wilander 2018-03-01 10:59:33 PST
A bunch of the resource load statistics tests use js-test-pre.js without a corresponding js-test-post.js or js-test-post-async.js. We should move them to js-test.js. This may address some of the flakiness seen on the bots.
Comment 1 Radar WebKit Bug Importer 2018-03-01 11:04:38 PST
<rdar://problem/38033096>
Comment 2 Radar WebKit Bug Importer 2018-03-01 11:04:41 PST
<rdar://problem/38033103>
Comment 3 John Wilander 2018-03-01 11:07:57 PST
I will use <rdar://problem/38033096> as the Radar equivalent.
Comment 4 John Wilander 2018-03-01 11:11:18 PST
Created attachment 334827 [details]
Patch
Comment 5 Build Bot 2018-03-01 12:41:43 PST
Comment on attachment 334827 [details]
Patch

Attachment 334827 [details] did not pass ios-sim-ews (ios-simulator-wk2):
Output: http://webkit-queues.webkit.org/results/6723378

New failing tests:
http/tests/resourceLoadStatistics/partitioned-and-unpartitioned-cookie-deletion.html
Comment 6 Build Bot 2018-03-01 12:41:44 PST
Created attachment 334841 [details]
Archive of layout-test-results from ews121 for ios-simulator-wk2

The attached test failures were seen while running run-webkit-tests on the ios-sim-ews.
Bot: ews121  Port: ios-simulator-wk2  Platform: Mac OS X 10.12.6
Comment 7 John Wilander 2018-03-01 13:16:31 PST
Created attachment 334845 [details]
Patch
Comment 8 WebKit Commit Bot 2018-03-01 15:22:16 PST
Comment on attachment 334845 [details]
Patch

Clearing flags on attachment: 334845

Committed r229152: <https://trac.webkit.org/changeset/229152>
Comment 9 WebKit Commit Bot 2018-03-01 15:22:17 PST
All reviewed patches have been landed.  Closing bug.