Bug 183227 - Multiple media/*-require-user-gesture.html layout tests are flaky.
Summary: Multiple media/*-require-user-gesture.html layout tests are flaky.
Status: RESOLVED DUPLICATE of bug 185962
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-02-28 15:19 PST by Matt Lewis
Modified: 2018-05-29 10:12 PDT (History)
6 users (show)

See Also:


Attachments
Patch (1.45 KB, patch)
2018-05-29 09:55 PDT, Dawei Fenton (:realdawei)
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Matt Lewis 2018-02-28 15:19:13 PST
The following Layout tests are flaky on iOS Simulators and macOS

LayoutTests/media/video-play-require-user-gesture.html
https://webkit-test-results.webkit.org/dashboards/flakiness_dashboard.html#showAllRuns=true&tests=media%2Fvideo-play-audio-require-user-gesture.html

LayoutTests/media/video-play-audio-require-user-gesture.html
https://webkit-test-results.webkit.org/dashboards/flakiness_dashboard.html#showAllRuns=true&tests=media%2Fvideo-play-audio-require-user-gesture.html

LayoutTests/media/video-play-require-user-gesture.html
https://webkit-test-results.webkit.org/dashboards/flakiness_dashboard.html#showAllRuns=true&tests=media%2Fvideo-trackmenu-selection.html

The test generally fail together.

sample diff:
--- /Volumes/Data/slave/sierra-release-tests-wk2/build/layout-test-results/media/video-play-audio-require-user-gesture-expected.txt
+++ /Volumes/Data/slave/sierra-release-tests-wk2/build/layout-test-results/media/video-play-audio-require-user-gesture-actual.txt
@@ -9,10 +9,6 @@
 EXPECTED (video.paused == 'true') OK
 
 * User gesture initiated
-EVENT(playing)
-RUN(video.pause())
-EVENT(pause)
-EXPECTED (video.paused == 'true') OK
-RUN(video.webkitEnterFullScreen())
+undefined FAIL
 END OF TEST
 

all diffs have the undefined FAIL at some point in the output

https://build.webkit.org/results/Apple%20Sierra%20Release%20WK2%20(Tests)/r229100%20(7878)/results.html
https://build.webkit.org/builders/Apple%20Sierra%20Release%20WK2%20(Tests)/builds/7878
Comment 1 Ryan Haddad 2018-04-13 16:53:36 PDT
This is still happening.
Comment 2 Dawei Fenton (:realdawei) 2018-05-23 16:58:50 PDT
Update TestExpectations to reflect the two tests that have proven to be flaky. They generally fail together.

media/video-play-audio-require-user-gesture.html 
media/video-play-require-user-gesture.html 

https://build.webkit.org/builders/Apple%20Sierra%20Release%20WK2%20(Tests)/builds/9549/steps/layout-test/logs/stdio

Regressions: Unexpected text-only failures (3)
  media/video-play-audio-require-user-gesture.html [ Failure ]
  media/video-play-require-user-gesture.html [ Failure ]
  media/video-trackmenu-selection.html [ Failure ]
Comment 3 Dawei Fenton (:realdawei) 2018-05-29 09:55:21 PDT
Created attachment 341492 [details]
Patch
Comment 4 Ryan Haddad 2018-05-29 10:12:08 PDT

*** This bug has been marked as a duplicate of bug 185962 ***