Bug 183011 - [CMake] Expose HAVE macros globally
Summary: [CMake] Expose HAVE macros globally
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Don Olmstead
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2018-02-21 11:58 PST by Don Olmstead
Modified: 2018-02-22 11:03 PST (History)
8 users (show)

See Also:


Attachments
Patch (6.02 KB, patch)
2018-02-21 12:01 PST, Don Olmstead
no flags Details | Formatted Diff | Diff
Patch (5.46 KB, patch)
2018-02-21 12:03 PST, Don Olmstead
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Don Olmstead 2018-02-21 11:58:38 PST
Currently all the macros wrapping platform HAVE checks are locally scoped. These should be available in other CMake files.
Comment 1 Don Olmstead 2018-02-21 12:01:05 PST
Created attachment 334398 [details]
Patch
Comment 2 Don Olmstead 2018-02-21 12:03:07 PST
Created attachment 334400 [details]
Patch
Comment 3 Don Olmstead 2018-02-21 12:05:53 PST
I am planning on using these changes in https://bugs.webkit.org/show_bug.cgi?id=182891 and figured I'd get this reviewed on its own while I wait for Per Arne to check that WIP patch to make sure it works for Apple's internal windows build.
Comment 4 WebKit Commit Bot 2018-02-21 14:34:06 PST
Comment on attachment 334400 [details]
Patch

Clearing flags on attachment: 334400

Committed r228900: <https://trac.webkit.org/changeset/228900>
Comment 5 WebKit Commit Bot 2018-02-21 14:34:07 PST
All reviewed patches have been landed.  Closing bug.
Comment 6 Radar WebKit Bug Importer 2018-02-21 14:35:33 PST
<rdar://problem/37761582>
Comment 7 Konstantin Tokarev 2018-02-22 11:03:41 PST
Comment on attachment 334400 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=334400&action=review

> Source/cmake/OptionsCommon.cmake:119
> +WEBKIT_CHECK_HAVE_INCLUDE(HAVE_FEATURES_H features.h)

I think WEBKIT_CHECK_INCLUDE would be a better name