Bug 182910 - REGRESSION (r219342): Touch event coordinates and elementFromPoint coordinates differ
Summary: REGRESSION (r219342): Touch event coordinates and elementFromPoint coordinate...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Tim Horton
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2018-02-17 23:05 PST by Tim Horton
Modified: 2018-02-19 15:32 PST (History)
8 users (show)

See Also:


Attachments
Patch (10.01 KB, patch)
2018-02-17 23:05 PST, Tim Horton
no flags Details | Formatted Diff | Diff
Archive of layout-test-results from ews102 for mac-sierra (2.21 MB, application/zip)
2018-02-18 00:05 PST, EWS Watchlist
no flags Details
Archive of layout-test-results from ews105 for mac-sierra-wk2 (2.57 MB, application/zip)
2018-02-18 00:11 PST, EWS Watchlist
no flags Details
Archive of layout-test-results from ews113 for mac-sierra (2.92 MB, application/zip)
2018-02-18 00:30 PST, EWS Watchlist
no flags Details
Archive of layout-test-results from ews125 for ios-simulator-wk2 (2.15 MB, application/zip)
2018-02-18 00:37 PST, EWS Watchlist
no flags Details
Archive of layout-test-results from ews202 for win-future (11.59 MB, application/zip)
2018-02-18 00:51 PST, EWS Watchlist
no flags Details
Patch (6.40 KB, patch)
2018-02-19 12:15 PST, Tim Horton
no flags Details | Formatted Diff | Diff
Patch (14.45 KB, patch)
2018-02-19 13:22 PST, Tim Horton
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Tim Horton 2018-02-17 23:05:15 PST
REGRESSION (r219342): Touch event coordinates and elementFromPoint coordinates differ
Comment 1 Tim Horton 2018-02-17 23:05:27 PST
Created attachment 334116 [details]
Patch
Comment 2 EWS Watchlist 2018-02-18 00:05:54 PST Comment hidden (obsolete)
Comment 3 EWS Watchlist 2018-02-18 00:05:55 PST Comment hidden (obsolete)
Comment 4 EWS Watchlist 2018-02-18 00:11:37 PST Comment hidden (obsolete)
Comment 5 EWS Watchlist 2018-02-18 00:11:38 PST Comment hidden (obsolete)
Comment 6 EWS Watchlist 2018-02-18 00:30:21 PST Comment hidden (obsolete)
Comment 7 EWS Watchlist 2018-02-18 00:30:22 PST Comment hidden (obsolete)
Comment 8 EWS Watchlist 2018-02-18 00:37:15 PST Comment hidden (obsolete)
Comment 9 EWS Watchlist 2018-02-18 00:37:16 PST Comment hidden (obsolete)
Comment 10 EWS Watchlist 2018-02-18 00:50:39 PST Comment hidden (obsolete)
Comment 11 EWS Watchlist 2018-02-18 00:51:01 PST Comment hidden (obsolete)
Comment 12 Simon Fraser (smfr) 2018-02-19 10:43:57 PST
Comment on attachment 334116 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=334116&action=review

> Source/WebCore/ChangeLog:12
> +        We reverted other changes to the definition of client coordinates
> +        in r219829 due to compatibility concerns. However, we failed to revert
> +        r219342 on trunk, leaving elementFromPoint() using coordinates relative
> +        to the layout viewport.

I think the right thing to do here is to add a settings, like "clientCoordinatesRelativeToLayoutViewport", and make all these changes conditional. Layout-viewport-relative coords are the future, so we should skate etc.
Comment 13 Tim Horton 2018-02-19 10:55:50 PST
(In reply to Simon Fraser (smfr) from comment #12)
> Comment on attachment 334116 [details]
> Patch
> 
> View in context:
> https://bugs.webkit.org/attachment.cgi?id=334116&action=review
> 
> > Source/WebCore/ChangeLog:12
> > +        We reverted other changes to the definition of client coordinates
> > +        in r219829 due to compatibility concerns. However, we failed to revert
> > +        r219342 on trunk, leaving elementFromPoint() using coordinates relative
> > +        to the layout viewport.
> 
> I think the right thing to do here is to add a settings, like
> "clientCoordinatesRelativeToLayoutViewport", and make all these changes
> conditional. Layout-viewport-relative coords are the future, so we should
> skate etc.

Agreed, that makes sense. Do you want me to do this for this patch and have the switch only switch elementFromPoint?
Comment 14 Tim Horton 2018-02-19 12:15:08 PST
Created attachment 334174 [details]
Patch
Comment 15 Tim Horton 2018-02-19 13:22:17 PST
Created attachment 334180 [details]
Patch
Comment 16 WebKit Commit Bot 2018-02-19 15:30:32 PST
Comment on attachment 334180 [details]
Patch

Clearing flags on attachment: 334180

Committed r228714: <https://trac.webkit.org/changeset/228714>
Comment 17 WebKit Commit Bot 2018-02-19 15:30:35 PST
All reviewed patches have been landed.  Closing bug.
Comment 18 Radar WebKit Bug Importer 2018-02-19 15:32:33 PST
<rdar://problem/37688387>