Bug 18290 - Acid3 Test 79 random failure
Summary: Acid3 Test 79 random failure
Status: RESOLVED WONTFIX
Alias: None
Product: WebKit
Classification: Unclassified
Component: SVG (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh Intel OS X 10.5
: P2 Normal
Assignee: Nobody
URL: http://acid3.acidtests.org
Keywords:
Depends on:
Blocks: Acid3
  Show dependency treegraph
 
Reported: 2008-04-02 15:26 PDT by Garret Huntress
Modified: 2014-05-12 05:19 PDT (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Garret Huntress 2008-04-02 15:26:51 PDT
I've been using r31446 all day, and decided to give the acid3 test another whirl this afternoon (to stare at that 100/100 glory), but I was shocked to see test 79 fail the first time around:

Test 79 failed: character position 6, which is between a normal character, which has some kerning after it, and the first character of a two-character glyph, which has some kerning before it, is 21600 but should be 21800

Immediate reload and it went back to 100/100.  Took screen shots of both states (Before and after reload).

-Garret
Comment 1 Eric Seidel (no email) 2008-04-13 22:26:27 PDT
I'm pretty sure we have a dupe of this.  I think Acid3 actually has timing issues.  It doesn't force the font load to be synchronous.
Comment 2 Dirk Schulze 2014-05-12 05:19:53 PDT
I think we fixed that a while back. Can't reproduce.