Bug 182879 - Layout Test http/tests/resourceLoadStatistics/classify-as-prevalent-based-on-top-frame-redirect-collusion.html is a flaky failure
Summary: Layout Test http/tests/resourceLoadStatistics/classify-as-prevalent-based-on-...
Status: RESOLVED DUPLICATE of bug 182983
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-02-16 10:47 PST by Ryan Haddad
Modified: 2018-02-20 13:18 PST (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ryan Haddad 2018-02-16 10:47:40 PST
The following layout test is flaky on macOS WK2

http/tests/resourceLoadStatistics/classify-as-prevalent-based-on-top-frame-redirect-collusion.html

Probable cause:

The test was added with https://trac.webkit.org/changeset/228416/webkit

Flakiness Dashboard:

https://webkit-test-results.webkit.org/dashboards/flakiness_dashboard.html#showAllRuns=true&tests=http%2Ftests%2FresourceLoadStatistics%2Fclassify-as-prevalent-based-on-top-frame-redirect-collusion.html

--- /Volumes/Data/slave/sierra-release-tests-wk2/build/layout-test-results/http/tests/resourceLoadStatistics/classify-as-prevalent-based-on-top-frame-redirect-collusion-expected.txt
+++ /Volumes/Data/slave/sierra-release-tests-wk2/build/layout-test-results/http/tests/resourceLoadStatistics/classify-as-prevalent-based-on-top-frame-redirect-collusion-actual.txt
@@ -3,12 +3,4 @@
 On success, you will see a series of "PASS" messages, followed by "TEST COMPLETE".
 
 
-PASS Colluding host 1 got set as prevalent resource.
-PASS Colluding host 2 got set as prevalent resource.
-PASS Colluding host 3 got set as prevalent resource.
-PASS Colluding host 4 got set as prevalent resource.
-PASS Colluding localhost got set as prevalent resource after actual navigational redirect.
-PASS successfullyParsed is true
 
-TEST COMPLETE
-
Comment 1 Matt Lewis 2018-02-20 13:18:39 PST

*** This bug has been marked as a duplicate of bug 182983 ***