Bug 182606 - CoreAudioCaptureSourceIOSListener should be a WebProcess singleton
Summary: CoreAudioCaptureSourceIOSListener should be a WebProcess singleton
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Service Workers (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: youenn fablet
URL:
Keywords: InRadar
: 179964 (view as bug list)
Depends on:
Blocks:
 
Reported: 2018-02-08 09:47 PST by youenn fablet
Modified: 2018-08-14 05:37 PDT (History)
7 users (show)

See Also:


Attachments
Patch (12.07 KB, patch)
2018-02-08 10:15 PST, youenn fablet
no flags Details | Formatted Diff | Diff
Patch (13.49 KB, patch)
2018-02-08 12:34 PST, youenn fablet
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description youenn fablet 2018-02-08 09:47:30 PST
Currently, there is one listener per capture source.
Comment 1 Radar WebKit Bug Importer 2018-02-08 09:48:14 PST
<rdar://problem/37355283>
Comment 2 youenn fablet 2018-02-08 10:15:36 PST
Created attachment 333385 [details]
Patch
Comment 3 EWS Watchlist 2018-02-08 10:17:42 PST
Attachment 333385 [details] did not pass style-queue:


ERROR: Source/WebCore/platform/mediastream/ios/CoreAudioCaptureSourceIOS.mm:126:  Missing spaces around :  [whitespace/init] [4]
Total errors found: 1 in 5 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 4 Eric Carlson 2018-02-08 10:43:37 PST
Comment on attachment 333385 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=333385&action=review

> Source/WebCore/platform/mediastream/mac/CoreAudioCaptureSource.cpp:773
> +    if (unit.isSuspended())
> +        unit.reconfigureAudioUnit();

I'm not sure this is a good idea. What happens if a page that already has user permission calls getUserMedia({audio:true}) during an interruption?
Comment 5 youenn fablet 2018-02-08 12:34:00 PST
Created attachment 333409 [details]
Patch
Comment 6 EWS Watchlist 2018-02-08 12:42:31 PST
Attachment 333409 [details] did not pass style-queue:


ERROR: Source/WebCore/platform/mediastream/ios/CoreAudioCaptureSourceIOS.mm:126:  Missing spaces around :  [whitespace/init] [4]
Total errors found: 1 in 5 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 7 WebKit Commit Bot 2018-02-08 21:05:27 PST
Comment on attachment 333409 [details]
Patch

Clearing flags on attachment: 333409

Committed r228310: <https://trac.webkit.org/changeset/228310>
Comment 8 WebKit Commit Bot 2018-02-08 21:05:29 PST
All reviewed patches have been landed.  Closing bug.
Comment 9 Jon Lee 2018-02-20 18:53:01 PST
*** Bug 179964 has been marked as a duplicate of this bug. ***