WEBKIT_MAKE_FORWARDING_HEADERS isn't actually making forwarding headers its copying in the same manner that Xcode builds do for frameworks.
Created attachment 333348 [details] Patch
Comment on attachment 333348 [details] Patch I think naming macro "INSTALL" suggests that it should do install() internally, but this is not the case
Yeah I agree with Konstantin, the current name actually seems better to me.
(In reply to Michael Catanzaro from comment #3) > Yeah I agree with Konstantin, the current name actually seems better to me. How about WEBKIT_COPY_FRAMEWORK_HEADERS?
(In reply to Don Olmstead from comment #4) > (In reply to Michael Catanzaro from comment #3) > > Yeah I agree with Konstantin, the current name actually seems better to me. > > How about WEBKIT_COPY_FRAMEWORK_HEADERS? Or actually WEBKIT_MAKE_FRAMEWORK_HEADERS? Forwarding isnt what its actually doing so I think that part needs to be dropped either way.
MAKE_FLATTENED_HEADERS?
(In reply to Michael Catanzaro from comment #6) > MAKE_FLATTENED_HEADERS? Its emulating what Cocoa frameworks do so thats why I said FRAMEWORK. I just don't want FORWARDING in there since that's what we're trying to nuke from orbit. Also WTF and PAL will be doing this but they aren't technically flat at least not YET.
I think WEBKIT_MAKE_FRAMEWORK_HEADERS should be unified into WEBKIT_FRAMEWORK and WEBKIT_FRAMEWORK should take arguments. WEBKIT_FRAMEWORK( WebCore PRIVATE_HEADER ... PUBLIC_HEADER ... PUBLIC_DERIRIVED_HEADER ... SOURCES ... ...)
Comment on attachment 333348 [details] Patch View in context: https://bugs.webkit.org/attachment.cgi?id=333348&action=review > ChangeLog:10 > + consistent with the actual behavior. You want to rename the directory name ForwardingHeaders, too?
(In reply to Fujii Hironori from comment #8) > I think WEBKIT_MAKE_FRAMEWORK_HEADERS should be unified into > WEBKIT_FRAMEWORK and WEBKIT_FRAMEWORK should take arguments. > > WEBKIT_FRAMEWORK( > WebCore > PRIVATE_HEADER ... > PUBLIC_HEADER ... > PUBLIC_DERIRIVED_HEADER ... > SOURCES ... > ...) Yea that makes sense. Might want the same behavior as it has with SOURCES and all that. (In reply to Fujii Hironori from comment #9) > Comment on attachment 333348 [details] > Patch > > View in context: > https://bugs.webkit.org/attachment.cgi?id=333348&action=review > > > ChangeLog:10 > > + consistent with the actual behavior. > > You want to rename the directory name ForwardingHeaders, too? I was thinking of doing something along those lines yes, but in a cleanup pass after everything is done.