Bug 182467 - Uncaught Exception: TypeError: failed to initialize NumberFormat due to invalid locale
Summary: Uncaught Exception: TypeError: failed to initialize NumberFormat due to inval...
Status: RESOLVED DUPLICATE of bug 167991
Alias: None
Product: WebKit
Classification: Unclassified
Component: Web Inspector (show other bugs)
Version: WebKit Nightly Build
Hardware: All All
: P2 Normal
Assignee: Nobody
URL:
Keywords:
: 183032 (view as bug list)
Depends on:
Blocks:
 
Reported: 2018-02-04 01:53 PST by laurb3st
Modified: 2018-07-25 13:46 PDT (History)
4 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description laurb3st 2018-02-04 01:53:38 PST
-------
Inspected URL:        (unknown)
Loading completed:    false
Frontend User Agent:  Mozilla/5.0 (X11; Fedora; Linux x86_64) AppleWebKit/605.1 (KHTML, like Gecko) Version/11.0 Safari/605.1

Uncaught Exceptions:
 - TypeError: failed to initialize NumberFormat due to invalid locale (at Utilities.js:801:57)
    NumberFormat @ [native code]
    toLocaleString @ [native code]
    d @ Utilities.js:801:57
    value @ Utilities.js:881:64
    value @ Utilities.js:899:29
    _loadNewRecording @ TimelineManager.js:655:108
    reset @ TimelineManager.js:114:31
    TimelineManager @ TimelineManager.js:62:19
    loaded @ Main.js:130:50
    global code @ Main.html:808:18
-------

* STEPS TO REPRODUCE
1. What were you doing? Include setup or other preparations to reproduce the exception.
2. Include explicit, accurate, and minimal steps taken. Do not include extraneous or irrelevant steps.

* NOTES
Document any additional information that might be useful in resolving the problem, such as screen shots or other included attachments.
Comment 1 Joseph Pecoraro 2018-02-04 23:44:48 PST
Maybe this is a linux port issue?

The WebInspector code here is just doing: `number.toLocaleString()`

laurb3st, what do you get when you load the following test:

    <script>
    alert( (new Intl.DateTimeFormat).resolvedOptions().locale );
    </script>

It may be specific to your locale and the linux port.
Comment 2 Joseph Pecoraro 2018-02-22 10:47:06 PST
*** Bug 183032 has been marked as a duplicate of this bug. ***
Comment 3 Michael Catanzaro 2018-07-25 13:46:49 PDT

*** This bug has been marked as a duplicate of bug 167991 ***