Bug 182463 - Web Inspector: Styles: property highlight doesn't disappear when navigating from Computed to Styles
Summary: Web Inspector: Styles: property highlight doesn't disappear when navigating f...
Status: RESOLVED DUPLICATE of bug 192198
Alias: None
Product: WebKit
Classification: Unclassified
Component: Web Inspector (show other bugs)
Version: WebKit Nightly Build
Hardware: All All
: P2 Normal
Assignee: Nobody
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2018-02-03 19:48 PST by Nikita Vasilyev
Modified: 2018-12-05 19:28 PST (History)
2 users (show)

See Also:


Attachments
[Animated GIF] Bug (360.04 KB, image/gif)
2018-02-03 19:48 PST, Nikita Vasilyev
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Nikita Vasilyev 2018-02-03 19:48:15 PST
Created attachment 333043 [details]
[Animated GIF] Bug

Steps:
1. Open http://nv.github.io/webkit-inspector-bugs/styles-redesign/tests/commenting-rules.html
2. Inspect the purple square.
3. Open Computed panel in the right sidebar.
4. Click on the go-to arrow right next to "background-color: rgb(107, 0, 73)".
5. Open Computed panel again (or any panel other than Styles).
6. Open Styles panel.

Expected:
No yellow background property highlight.

Actual:
The yellow background property highlight is still there.

Notes:
A similar issue with navigating to a resource line has been around for years.
Comment 1 Radar WebKit Bug Importer 2018-02-03 19:49:43 PST
<rdar://problem/37202369>
Comment 2 Nikita Vasilyev 2018-12-05 19:28:14 PST
Property highlight was replaced by property selection.

*** This bug has been marked as a duplicate of bug 192198 ***