Bug 182335 - Update imagebitmap tests.
Summary: Update imagebitmap tests.
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Ms2ger (he/him; ⌚ UTC+1/+2)
URL:
Keywords: InRadar
Depends on: 182393
Blocks: 182424
  Show dependency treegraph
 
Reported: 2018-01-31 08:50 PST by Ms2ger (he/him; ⌚ UTC+1/+2)
Modified: 2018-02-05 10:30 PST (History)
7 users (show)

See Also:


Attachments
Patch (47.50 KB, patch)
2018-01-31 08:53 PST, Ms2ger (he/him; ⌚ UTC+1/+2)
no flags Details | Formatted Diff | Diff
Archive of layout-test-results from ews101 for mac-sierra (2.35 MB, application/zip)
2018-01-31 09:43 PST, Build Bot
no flags Details
Archive of layout-test-results from ews106 for mac-sierra-wk2 (2.73 MB, application/zip)
2018-01-31 09:49 PST, Build Bot
no flags Details
Archive of layout-test-results from ews114 for mac-sierra (3.02 MB, application/zip)
2018-01-31 10:17 PST, Build Bot
no flags Details
Archive of layout-test-results from ews125 for ios-simulator-wk2 (2.19 MB, application/zip)
2018-01-31 10:22 PST, Build Bot
no flags Details
Patch (63.08 KB, patch)
2018-02-01 02:43 PST, Ms2ger (he/him; ⌚ UTC+1/+2)
no flags Details | Formatted Diff | Diff
Patch (75.61 KB, patch)
2018-02-02 01:27 PST, Ms2ger (he/him; ⌚ UTC+1/+2)
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Ms2ger (he/him; ⌚ UTC+1/+2) 2018-01-31 08:50:52 PST
.
Comment 1 Ms2ger (he/him; ⌚ UTC+1/+2) 2018-01-31 08:53:48 PST
Created attachment 332764 [details]
Patch
Comment 2 Build Bot 2018-01-31 09:43:37 PST
Comment on attachment 332764 [details]
Patch

Attachment 332764 [details] did not pass mac-ews (mac):
Output: http://webkit-queues.webkit.org/results/6291537

New failing tests:
imported/w3c/web-platform-tests/2dcontext/imagebitmap/createImageBitmap-origin.sub.html
imported/w3c/web-platform-tests/2dcontext/imagebitmap/createImageBitmap-drawImage.html
imported/w3c/web-platform-tests/2dcontext/imagebitmap/createImageBitmap-invalid-args.html
Comment 3 Build Bot 2018-01-31 09:43:39 PST
Created attachment 332771 [details]
Archive of layout-test-results from ews101 for mac-sierra

The attached test failures were seen while running run-webkit-tests on the mac-ews.
Bot: ews101  Port: mac-sierra  Platform: Mac OS X 10.12.6
Comment 4 Build Bot 2018-01-31 09:49:17 PST
Comment on attachment 332764 [details]
Patch

Attachment 332764 [details] did not pass mac-wk2-ews (mac-wk2):
Output: http://webkit-queues.webkit.org/results/6291606

New failing tests:
imported/w3c/web-platform-tests/2dcontext/imagebitmap/createImageBitmap-origin.sub.html
imported/w3c/web-platform-tests/2dcontext/imagebitmap/createImageBitmap-drawImage.html
imported/w3c/web-platform-tests/2dcontext/imagebitmap/createImageBitmap-invalid-args.html
Comment 5 Build Bot 2018-01-31 09:49:18 PST
Created attachment 332772 [details]
Archive of layout-test-results from ews106 for mac-sierra-wk2

The attached test failures were seen while running run-webkit-tests on the mac-wk2-ews.
Bot: ews106  Port: mac-sierra-wk2  Platform: Mac OS X 10.12.6
Comment 6 Build Bot 2018-01-31 10:17:09 PST
Comment on attachment 332764 [details]
Patch

Attachment 332764 [details] did not pass mac-debug-ews (mac):
Output: http://webkit-queues.webkit.org/results/6292060

New failing tests:
imported/w3c/web-platform-tests/2dcontext/imagebitmap/createImageBitmap-origin.sub.html
imported/w3c/web-platform-tests/2dcontext/imagebitmap/createImageBitmap-drawImage.html
imported/w3c/web-platform-tests/2dcontext/imagebitmap/createImageBitmap-invalid-args.html
Comment 7 Build Bot 2018-01-31 10:17:10 PST
Created attachment 332776 [details]
Archive of layout-test-results from ews114 for mac-sierra

The attached test failures were seen while running run-webkit-tests on the mac-debug-ews.
Bot: ews114  Port: mac-sierra  Platform: Mac OS X 10.12.6
Comment 8 Build Bot 2018-01-31 10:22:02 PST
Comment on attachment 332764 [details]
Patch

Attachment 332764 [details] did not pass ios-sim-ews (ios-simulator-wk2):
Output: http://webkit-queues.webkit.org/results/6292118

New failing tests:
imported/w3c/web-platform-tests/2dcontext/imagebitmap/createImageBitmap-origin.sub.html
imported/w3c/web-platform-tests/2dcontext/imagebitmap/createImageBitmap-drawImage.html
imported/w3c/web-platform-tests/2dcontext/imagebitmap/createImageBitmap-invalid-args.html
Comment 9 Build Bot 2018-01-31 10:22:03 PST
Created attachment 332777 [details]
Archive of layout-test-results from ews125 for ios-simulator-wk2

The attached test failures were seen while running run-webkit-tests on the ios-sim-ews.
Bot: ews125  Port: ios-simulator-wk2  Platform: Mac OS X 10.12.6
Comment 10 Ms2ger (he/him; ⌚ UTC+1/+2) 2018-02-01 02:43:51 PST
Created attachment 332863 [details]
Patch
Comment 11 WebKit Commit Bot 2018-02-01 03:16:15 PST
Comment on attachment 332863 [details]
Patch

Clearing flags on attachment: 332863

Committed r227958: <https://trac.webkit.org/changeset/227958>
Comment 12 WebKit Commit Bot 2018-02-01 03:16:16 PST
All reviewed patches have been landed.  Closing bug.
Comment 13 Radar WebKit Bug Importer 2018-02-01 03:31:30 PST
<rdar://problem/37110684>
Comment 14 Matt Lewis 2018-02-01 10:14:04 PST
This caused a consistent assertion failure with the test imported/w3c/web-platform-tests/2dcontext/imagebitmap/createImageBitmap-origin.sub.html on all of macOS.

https://build.webkit.org/results/Apple%20High%20Sierra%20Debug%20WK2%20(Tests)/r227962%20(1884)/results.html

ASSERTION FAILED: WTF::isMainThread()
/Volumes/Data/slave/highsierra-debug/build/Source/WebCore/loader/cache/MemoryCache.cpp(57) : static WebCore::MemoryCache &WebCore::MemoryCache::singleton()
1   0x1e06f605d WTFCrash
2   0x1d25b688a WebCore::MemoryCache::singleton()
3   0x1d252202f WebCore::SubresourceLoader::willCancel(WebCore::ResourceError const&)
4   0x1d250ca01 WebCore::ResourceLoader::cancel(WebCore::ResourceError const&)
5   0x1d250c94f WebCore::ResourceLoader::cancel()
6   0x1d252da22 WebCore::SubresourceLoader::willSendRequestInternal(WebCore::ResourceRequest&&, WebCore::ResourceResponse const&, WTF::CompletionHandler<void (WebCore::ResourceRequest&&)>&&)::$_0::operator()(WTF::CompletionHandler<void (WebCore::ResourceRequest&&)>&&, WebCore::ResourceRequest&&)::'lambda'(WebCore::ResourceRequest&&)::operator()(WebCore::ResourceRequest&&)
7   0x1d252d8d4 WTF::Function<void (WebCore::ResourceRequest&&)>::CallableWrapper<WebCore::SubresourceLoader::willSendRequestInternal(WebCore::ResourceRequest&&, WebCore::ResourceResponse const&, WTF::CompletionHandler<void (WebCore::ResourceRequest&&)>&&)::$_0::operator()(WTF::CompletionHandler<void (WebCore::ResourceRequest&&)>&&, WebCore::ResourceRequest&&)::'lambda'(WebCore::ResourceRequest&&)>::call(WebCore::ResourceRequest&&)
8   0x1d0b257ee WTF::Function<void (WebCore::ResourceRequest&&)>::operator()(WebCore::ResourceRequest&&) const
9   0x1d0b256f9 WTF::CompletionHandler<void (WebCore::ResourceRequest&&)>::operator()(WebCore::ResourceRequest&&) const
10  0x1d250bf3a WebCore::ResourceLoader::willSendRequestInternal(WebCore::ResourceRequest&&, WebCore::ResourceResponse const&, WTF::CompletionHandler<void (WebCore::ResourceRequest&&)>&&)
11  0x1d2520471 WebCore::SubresourceLoader::willSendRequestInternal(WebCore::ResourceRequest&&, WebCore::ResourceResponse const&, WTF::CompletionHandler<void (WebCore::ResourceRequest&&)>&&)::$_0::operator()(WTF::CompletionHandler<void (WebCore::ResourceRequest&&)>&&, WebCore::ResourceRequest&&)
12  0x1d2530de4 WebCore::SubresourceLoader::willSendRequestInternal(WebCore::ResourceRequest&&, WebCore::ResourceResponse const&, WTF::CompletionHandler<void (WebCore::ResourceRequest&&)>&&)::$_3::operator()(WebCore::ResourceRequest&&)
13  0x1d2530cf4 WTF::Function<void (WebCore::ResourceRequest&&)>::CallableWrapper<WebCore::SubresourceLoader::willSendRequestInternal(WebCore::ResourceRequest&&, WebCore::ResourceResponse const&, WTF::CompletionHandler<void (WebCore::ResourceRequest&&)>&&)::$_3>::call(WebCore::ResourceRequest&&)
14  0x1d0b257ee WTF::Function<void (WebCore::ResourceRequest&&)>::operator()(WebCore::ResourceRequest&&) const
15  0x1d0b256f9 WTF::CompletionHandler<void (WebCore::ResourceRequest&&)>::operator()(WebCore::ResourceRequest&&) const
16  0x1d258387b WebCore::CachedResource::redirectReceived(WebCore::ResourceRequest&&, WebCore::ResourceResponse const&, WTF::CompletionHandler<void (WebCore::ResourceRequest&&)>&&)
17  0x1d25a1cfc WebCore::CachedRawResource::redirectReceived(WebCore::ResourceRequest&&, WebCore::ResourceResponse const&, WTF::CompletionHandler<void (WebCore::ResourceRequest&&)>&&)::$_1::operator()(WebCore::ResourceRequest&&)
18  0x1d25a1bd4 WTF::Function<void (WebCore::ResourceRequest&&)>::CallableWrapper<WebCore::CachedRawResource::redirectReceived(WebCore::ResourceRequest&&, WebCore::ResourceResponse const&, WTF::CompletionHandler<void (WebCore::ResourceRequest&&)>&&)::$_1>::call(WebCore::ResourceRequest&&)
19  0x1d0b257ee WTF::Function<void (WebCore::ResourceRequest&&)>::operator()(WebCore::ResourceRequest&&) const
20  0x1d0b256f9 WTF::CompletionHandler<void (WebCore::ResourceRequest&&)>::operator()(WebCore::ResourceRequest&&) const
21  0x1d258398b WebCore::iterateClients(WebCore::CachedResourceClientWalker<WebCore::CachedRawResourceClient>&&, WebCore::CachedResourceHandle<WebCore::CachedRawResource>&&, WebCore::ResourceRequest&&, std::__1::unique_ptr<WebCore::ResourceResponse, std::__1::default_delete<WebCore::ResourceResponse> >&&, WTF::CompletionHandler<void (WebCore::ResourceRequest&&)>&&)
22  0x1d2597bd1 WebCore::iterateClients(WebCore::CachedResourceClientWalker<WebCore::CachedRawResourceClient>&&, WebCore::CachedResourceHandle<WebCore::CachedRawResource>&&, WebCore::ResourceRequest&&, std::__1::unique_ptr<WebCore::ResourceResponse, std::__1::default_delete<WebCore::ResourceResponse> >&&, WTF::CompletionHandler<void (WebCore::ResourceRequest&&)>&&)::$_5::operator()(WebCore::ResourceRequest&&)
23  0x1d2597934 WTF::Function<void (WebCore::ResourceRequest&&)>::CallableWrapper<WebCore::iterateClients(WebCore::CachedResourceClientWalker<WebCore::CachedRawResourceClient>&&, WebCore::CachedResourceHandle<WebCore::CachedRawResource>&&, WebCore::ResourceRequest&&, std::__1::unique_ptr<WebCore::ResourceResponse, std::__1::default_delete<WebCore::ResourceResponse> >&&, WTF::CompletionHandler<void (WebCore::ResourceRequest&&)>&&)::$_5>::call(WebCore::ResourceRequest&&)
24  0x1d0b257ee WTF::Function<void (WebCore::ResourceRequest&&)>::operator()(WebCore::ResourceRequest&&) const
25  0x1d0b256f9 WTF::CompletionHandler<void (WebCore::ResourceRequest&&)>::operator()(WebCore::ResourceRequest&&) const
26  0x1d34982d0 -[WebCoreNSURLSessionDataTask resource:receivedRedirect:request:completionHandler:]::$_11::operator()()
27  0x1d3497e59 WTF::Function<void ()>::CallableWrapper<-[WebCoreNSURLSessionDataTask resource:receivedRedirect:request:completionHandler:]::$_11>::call()
28  0x1d000d31b WTF::Function<void ()>::operator()() const
29  0x1d3490730 WTF::BlockPtr<void ()> WTF::BlockPtr<void ()>::fromCallable<WTF::Function<void ()> >(WTF::Function<void ()>)::'lambda'(void*)::operator()(void*) const
30  0x1d3490708 WTF::BlockPtr<void ()> WTF::BlockPtr<void ()>::fromCallable<WTF::Function<void ()> >(WTF::Function<void ()>)::'lambda'(void*)::__invoke(void*)
31  0x7fff349f622f __NSBLOCKOPERATION_IS_CALLING_OUT_TO_A_BLOCK__
LEAK: 2 WebPageProxy
Comment 15 Matt Lewis 2018-02-01 10:16:42 PST
(In reply to Matt Lewis from comment #14)
> This caused a consistent assertion failure with the test
> imported/w3c/web-platform-tests/2dcontext/imagebitmap/createImageBitmap-
> origin.sub.html on all of macOS.

Slight clarification. After this change this test started crashing consistently despite the changeling saying that it is only test gardening.
Comment 16 Matt Lewis 2018-02-01 10:17:42 PST
Also is there a reason that this was landed without EWS finishing on all platforms?
Comment 17 WebKit Commit Bot 2018-02-01 10:29:17 PST
Re-opened since this is blocked by bug 182393
Comment 18 Ms2ger (he/him; ⌚ UTC+1/+2) 2018-02-02 01:27:07 PST
Created attachment 332946 [details]
Patch
Comment 19 WebKit Commit Bot 2018-02-02 04:33:56 PST
Comment on attachment 332946 [details]
Patch

Clearing flags on attachment: 332946

Committed r228003: <https://trac.webkit.org/changeset/228003>
Comment 20 WebKit Commit Bot 2018-02-02 04:33:57 PST
All reviewed patches have been landed.  Closing bug.
Comment 21 Ms2ger (he/him; ⌚ UTC+1/+2) 2018-02-04 03:11:11 PST
*** Bug 182391 has been marked as a duplicate of this bug. ***