Bug 18197 - Render of vbolshov.org.ru/samples/svgraph failed
Summary: Render of vbolshov.org.ru/samples/svgraph failed
Status: RESOLVED INVALID
Alias: None
Product: WebKit
Classification: Unclassified
Component: SVG (show other bugs)
Version: 525.x (Safari 3.1)
Hardware: Macintosh OS X 10.5
: P2 Normal
Assignee: Nobody
URL: http://vbolshov.org.ru/samples/svgraph/
Keywords:
Depends on:
Blocks:
 
Reported: 2008-03-28 16:43 PDT by Eugene Pimenov
Modified: 2008-03-31 23:55 PDT (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Eugene Pimenov 2008-03-28 16:43:09 PDT
When you open this URL you'll different HTML in View Source and Web Inspector. And it produce syntax errors because of it. 
In opera and ff everything is OK.

Tested on nightly and 3.1
Comment 1 Alexey Proskuryakov 2008-03-31 23:48:19 PDT
This problem is caused by a function named "import" - this is a reserved word, so it cannot be used for a function name. See ECMAScript-262 paragraph 7.5.3.

According to bug 6179 comment 6, we also match IE here.
Comment 2 Alexey Proskuryakov 2008-03-31 23:55:37 PDT
I asked around, at it seems that we don't want to break the standard in this regard, closing as INVALID.