RESOLVED FIXED 181927
[YARR] Add diagnosis for YarrJIT failures
https://bugs.webkit.org/show_bug.cgi?id=181927
Summary [YARR] Add diagnosis for YarrJIT failures
Yusuke Suzuki
Reported 2018-01-22 02:00:35 PST
[YARR] Add diagnosis for YarrJIT failures
Attachments
Patch (10.14 KB, patch)
2018-01-22 02:02 PST, Yusuke Suzuki
no flags
Patch (10.16 KB, patch)
2018-01-22 02:10 PST, Yusuke Suzuki
no flags
Patch (12.96 KB, patch)
2018-01-28 20:35 PST, Yusuke Suzuki
no flags
Yusuke Suzuki
Comment 1 2018-01-22 02:02:38 PST
Yusuke Suzuki
Comment 2 2018-01-22 02:10:55 PST
Sam Weinig
Comment 3 2018-01-23 13:28:52 PST
Comment on attachment 331906 [details] Patch View in context: https://bugs.webkit.org/attachment.cgi?id=331906&action=review > Source/JavaScriptCore/yarr/YarrJIT.cpp:3505 > + std::optional<JITFailure> m_shouldFallBack; Perhaps this should be called m_failureReason > Source/JavaScriptCore/yarr/YarrJIT.h:53 > +enum class JITFailure { Perhaps a better name is JITFailureReason? > Source/JavaScriptCore/yarr/YarrJIT.h:85 > + void setFallBack(std::optional<JITFailure> fallBack) { m_fallBack = fallBack; } Perhaps a better name here would be setFallBackWithFailureReason (or something like that), since you failure reason enum is not what you are falling back to, but why you are falling back. I also think this could take a JITFailure (without the optional), since you never seem to call this with nullopt.
Yusuke Suzuki
Comment 4 2018-01-23 20:50:30 PST
Comment on attachment 331906 [details] Patch View in context: https://bugs.webkit.org/attachment.cgi?id=331906&action=review >> Source/JavaScriptCore/yarr/YarrJIT.cpp:3505 >> + std::optional<JITFailure> m_shouldFallBack; > > Perhaps this should be called m_failureReason Sounds nice, fixed. >> Source/JavaScriptCore/yarr/YarrJIT.h:53 >> +enum class JITFailure { > > Perhaps a better name is JITFailureReason? Nice, fixed. >> Source/JavaScriptCore/yarr/YarrJIT.h:85 >> + void setFallBack(std::optional<JITFailure> fallBack) { m_fallBack = fallBack; } > > Perhaps a better name here would be setFallBackWithFailureReason (or something like that), since you failure reason enum is not what you are falling back to, but why you are falling back. I also think this could take a JITFailure (without the optional), since you never seem to call this with nullopt. OK, sounds nice. Fixed.
Yusuke Suzuki
Comment 5 2018-01-23 20:51:13 PST
Radar WebKit Bug Importer
Comment 6 2018-01-23 20:52:37 PST
Yusuke Suzuki
Comment 7 2018-01-28 20:35:50 PST
Reopening to attach new patch.
Yusuke Suzuki
Comment 8 2018-01-28 20:35:52 PST
EWS Watchlist
Comment 9 2018-01-28 20:37:12 PST
Attachment 332504 [details] did not pass style-queue: ERROR: Source/JavaScriptCore/assembler/LinkBuffer.h:343: Wrong number of spaces before statement. (expected: 9) [whitespace/indent] [4] Total errors found: 1 in 4 files If any of these errors are false positives, please file a bug against check-webkit-style.
Yusuke Suzuki
Comment 10 2018-01-28 20:37:49 PST
Comment on attachment 332504 [details] Patch Oops, wrong bug id.
Note You need to log in before you can comment on or make changes to this bug.