Bug 18178 (smallmerchantship) - Website claims there is no SVG support
Summary: Website claims there is no SVG support
Status: RESOLVED WORKSFORME
Alias: smallmerchantship
Product: WebKit
Classification: Unclassified
Component: Evangelism (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh OS X 10.4
: P2 Normal
Assignee: Nobody
URL: http://smallmerchantship.com/ik/
Keywords:
Depends on: 17400
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-28 05:34 PDT by Dan Ross
Modified: 2009-12-02 10:56 PST (History)
5 users (show)

See Also:


Attachments
Screenshot of the error (129.02 KB, image/png)
2008-03-29 18:13 PDT, Dan Ross
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dan Ross 2008-03-28 05:34:29 PDT
When entering the website it claims there is no support for SVG graphics.
Comment 1 Dan Ross 2008-03-29 18:13:23 PDT
Created attachment 20203 [details]
Screenshot of the error
Comment 2 Dan Ross 2008-03-29 18:14:45 PDT
The shipping builds of Safari 3.1 do not have this problem.
Comment 3 Alexey Proskuryakov 2008-03-31 23:33:42 PDT
I'm seeing this problem on shipping Safari 3.1, too. Could you please double-check that it works for you?

From looking at the site code, the root cause appears to be bug 17400 - but this behavior has changed after Safari 3.0, not 3.1.
Comment 4 Dan Ross 2008-04-01 05:04:53 PDT
My mistake. You're correct. The shipping version of 3.1 does indeed have this problem.

(In reply to comment #3)
> I'm seeing this problem on shipping Safari 3.1, too. Could you please
> double-check that it works for you?
> 
> From looking at the site code, the root cause appears to be bug 17400 - but
> this behavior has changed after Safari 3.0, not 3.1.
> 

Comment 5 Alexey Proskuryakov 2008-04-01 05:15:16 PDT
Our behavior is correct to the letter of standard. The current consensus seems to be that we don't want to disobey the standard here, even though Firefox does, so moving to Evangelism.
Comment 6 Eric Seidel (no email) 2008-04-01 11:19:52 PDT
This will get fixed when we turn back on SVG_FILTER support.

FireFox is violating the spec if they claim to support any of these feature strings:

supported:function(){
var svgFeature="http://www.w3.org/TR/SVG11/feature#SVG";
var supported = (document.implementation && (document.implementation.hasFeature("org.w3c.svg","1.0") || document.implementation.hasFeature(svgFeature,"1.1")));
return supported;
}

Since all of those strings require SVG filter and SVG animation support.  Both of which we have partial implementations for, both of which were turned off for Safari 3.0 and 3.1.  We incorrectly claimed support of these feature strings in Safari 3.0 (beta), but it was fixed by the final version, IIRC.

We can keep this bug around, but mostly this is just site evangelism.  OpenLayers.js file is using the easy check (which requires all of SVG) instead of using finer-grained checks for the features it is actually using.

This bug will "fix itself" if we're successful in getting a GSoC student this summer interested in SVG Filter completion.
Comment 7 Eric Seidel (no email) 2008-04-01 11:21:25 PDT
If you're curious, the exact checks in our code which are causing this "bug" can be found here:
http://trac.webkit.org/projects/webkit/browser/trunk/WebCore/dom/DOMImplementation.cpp#L62
Comment 8 Eric Seidel (no email) 2008-04-01 11:42:00 PDT
I filed https://bugzilla.mozilla.org/show_bug.cgi?id=426384 with Mozilla about their feature strings.
Comment 9 Robert Blaut 2008-12-29 13:44:07 PST
I'm unable to load the reported site: http://smallmerchantship.com/ik/ 
Comment 10 Alexey Proskuryakov 2009-12-02 10:56:29 PST
The Firefox bug has been fixed, now they also don't claim to have full SVG support. No need to keep tracking this as evangelism bug, since we don't know any affected sites.