RESOLVED FIXED 181357
Storage Access API: Refactor to make naming accurate and explicit, simplify access table, and prepare for access removal for page
https://bugs.webkit.org/show_bug.cgi?id=181357
Summary Storage Access API: Refactor to make naming accurate and explicit, simplify a...
John Wilander
Reported 2018-01-05 17:01:33 PST
First, function and message names need to be changed to reflect how this was eventually implemented, i.e. access per frame. Second, the UI process doesn't need the ability to remove access since that is done directly by the web process. This means the UI process should only have explicit grant access functionality. Finally, the network process' entry table only needs to be able to give access to one domain in one frame at a time since access goes away on frame navigation. And it should use pageIDs as main keys to prepare for access removal for all frames under a page.
Attachments
Patch (40.02 KB, patch)
2018-01-05 17:18 PST, John Wilander
no flags
Radar WebKit Bug Importer
Comment 1 2018-01-05 17:03:34 PST
John Wilander
Comment 2 2018-01-05 17:18:19 PST
Alex Christensen
Comment 3 2018-01-05 17:23:54 PST
Comment on attachment 330615 [details] Patch View in context: https://bugs.webkit.org/attachment.cgi?id=330615&action=review > Source/WebCore/platform/network/cf/NetworkStorageSessionCFNet.cpp:290 > - auto it1 = m_framesGrantedStorageAccess.find(frameID); > + auto it1 = m_framesGrantedStorageAccess.find(pageID); This doesn't look right. If it is right you should rename m_framesGrantedStorageAccess to m_pagesGrantedStorageAccess.
John Wilander
Comment 4 2018-01-05 17:29:09 PST
(In reply to Alex Christensen from comment #3) > Comment on attachment 330615 [details] > Patch > > View in context: > https://bugs.webkit.org/attachment.cgi?id=330615&action=review > > > Source/WebCore/platform/network/cf/NetworkStorageSessionCFNet.cpp:290 > > - auto it1 = m_framesGrantedStorageAccess.find(frameID); > > + auto it1 = m_framesGrantedStorageAccess.find(pageID); > > This doesn't look right. If it is right you should rename > m_framesGrantedStorageAccess to m_pagesGrantedStorageAccess. It is right. Access is given to individual frames but since frameIDs are scoped to pageIDs, both are needed to identify a frame. The reasons why I changed from frameID to pageID as primary key are: 1. We want to be able to efficiently remove storage access for all frames on a page. 2. The pageID is the globally unique key. Does that make sense?
Alex Christensen
Comment 5 2018-01-05 17:30:53 PST
Comment on attachment 330615 [details] Patch yep. r=me
John Wilander
Comment 6 2018-01-05 17:56:41 PST
Comment on attachment 330615 [details] Patch Thanks, Alex!
WebKit Commit Bot
Comment 7 2018-01-05 18:16:54 PST
Comment on attachment 330615 [details] Patch Clearing flags on attachment: 330615 Committed r226482: <https://trac.webkit.org/changeset/226482>
WebKit Commit Bot
Comment 8 2018-01-05 18:16:56 PST
All reviewed patches have been landed. Closing bug.
Note You need to log in before you can comment on or make changes to this bug.