Bug 180817 - Introduce RenderTreeBuilder
Summary: Introduce RenderTreeBuilder
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Layout and Rendering (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords: InRadar
: 180896 (view as bug list)
Depends on:
Blocks:
 
Reported: 2017-12-14 10:12 PST by Antti Koivisto
Modified: 2017-12-16 11:08 PST (History)
8 users (show)

See Also:


Attachments
patch (108.45 KB, patch)
2017-12-14 10:21 PST, Antti Koivisto
no flags Details | Formatted Diff | Diff
patch (110.22 KB, patch)
2017-12-14 10:37 PST, Antti Koivisto
ews: commit-queue-
Details | Formatted Diff | Diff
Archive of layout-test-results from ews100 for mac-elcapitan (2.95 MB, application/zip)
2017-12-14 11:34 PST, Build Bot
no flags Details
Archive of layout-test-results from ews113 for mac-elcapitan (3.27 MB, application/zip)
2017-12-14 11:39 PST, Build Bot
no flags Details
patch (110.35 KB, patch)
2017-12-14 11:39 PST, Antti Koivisto
zalan: review+
ews: commit-queue-
Details | Formatted Diff | Diff
Archive of layout-test-results from ews114 for mac-elcapitan (2.35 MB, application/zip)
2017-12-14 12:53 PST, Build Bot
no flags Details
patch (112.68 KB, patch)
2017-12-14 15:14 PST, Antti Koivisto
ews: commit-queue-
Details | Formatted Diff | Diff
Archive of layout-test-results from ews115 for mac-elcapitan (3.14 MB, application/zip)
2017-12-14 17:37 PST, Build Bot
no flags Details
patch (114.66 KB, patch)
2017-12-15 00:45 PST, Antti Koivisto
ews: commit-queue-
Details | Formatted Diff | Diff
Archive of layout-test-results from ews101 for mac-elcapitan (589.43 KB, application/zip)
2017-12-15 01:16 PST, Build Bot
no flags Details
Archive of layout-test-results from ews116 for mac-elcapitan (1.49 MB, application/zip)
2017-12-15 01:32 PST, Build Bot
no flags Details
Archive of layout-test-results from ews106 for mac-elcapitan-wk2 (424.05 KB, application/zip)
2017-12-15 01:35 PST, Build Bot
no flags Details
Archive of layout-test-results from ews123 for ios-simulator-wk2 (700.12 KB, application/zip)
2017-12-15 01:51 PST, Build Bot
no flags Details
patch (118.22 KB, patch)
2017-12-15 01:55 PST, Antti Koivisto
no flags Details | Formatted Diff | Diff
Archive of layout-test-results from ews113 for mac-elcapitan (3.81 MB, application/zip)
2017-12-15 03:27 PST, Build Bot
no flags Details
patch (118.83 KB, patch)
2017-12-16 04:56 PST, Antti Koivisto
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Antti Koivisto 2017-12-14 10:12:20 PST
RenderTreeBuilder is responsible of building the render tree. Various renderer subtype specific addChild implementations will eventually move there.
Comment 1 zalan 2017-12-14 10:15:59 PST
r=me! :)
Comment 2 Antti Koivisto 2017-12-14 10:21:18 PST
Created attachment 329359 [details]
patch
Comment 3 Antti Koivisto 2017-12-14 10:37:21 PST
Created attachment 329363 [details]
patch
Comment 4 Build Bot 2017-12-14 11:34:30 PST
Comment on attachment 329363 [details]
patch

Attachment 329363 [details] did not pass mac-ews (mac):
Output: http://webkit-queues.webkit.org/results/5661702

Number of test failures exceeded the failure limit.
Comment 5 Build Bot 2017-12-14 11:34:31 PST
Created attachment 329370 [details]
Archive of layout-test-results from ews100 for mac-elcapitan

The attached test failures were seen while running run-webkit-tests on the mac-ews.
Bot: ews100  Port: mac-elcapitan  Platform: Mac OS X 10.11.6
Comment 6 Build Bot 2017-12-14 11:39:11 PST
Comment on attachment 329363 [details]
patch

Attachment 329363 [details] did not pass mac-debug-ews (mac):
Output: http://webkit-queues.webkit.org/results/5661493

Number of test failures exceeded the failure limit.
Comment 7 Build Bot 2017-12-14 11:39:12 PST
Created attachment 329371 [details]
Archive of layout-test-results from ews113 for mac-elcapitan

The attached test failures were seen while running run-webkit-tests on the mac-debug-ews.
Bot: ews113  Port: mac-elcapitan  Platform: Mac OS X 10.11.6
Comment 8 Antti Koivisto 2017-12-14 11:39:24 PST
Created attachment 329372 [details]
patch
Comment 9 zalan 2017-12-14 12:31:28 PST
Comment on attachment 329372 [details]
patch

This is awesome!
Comment 10 Build Bot 2017-12-14 12:53:53 PST
Comment on attachment 329372 [details]
patch

Attachment 329372 [details] did not pass mac-debug-ews (mac):
Output: http://webkit-queues.webkit.org/results/5662571

Number of test failures exceeded the failure limit.
Comment 11 Build Bot 2017-12-14 12:53:54 PST
Created attachment 329385 [details]
Archive of layout-test-results from ews114 for mac-elcapitan

The attached test failures were seen while running run-webkit-tests on the mac-debug-ews.
Bot: ews114  Port: mac-elcapitan  Platform: Mac OS X 10.11.6
Comment 12 Antti Koivisto 2017-12-14 15:14:51 PST
Created attachment 329407 [details]
patch
Comment 13 Ryosuke Niwa 2017-12-14 15:56:11 PST
Comment on attachment 329407 [details]
patch

View in context: https://bugs.webkit.org/attachment.cgi?id=329407&action=review

> Source/WebCore/rendering/RenderTreeBuilder.h:43
> +    // This is avoids having to convert all sites that need RenderTreeBuilder in one go.

Nit: This avoids?
Comment 14 Build Bot 2017-12-14 17:37:33 PST
Comment on attachment 329407 [details]
patch

Attachment 329407 [details] did not pass mac-debug-ews (mac):
Output: http://webkit-queues.webkit.org/results/5666467

New failing tests:
webgl/1.0.2/conformance/context/context-release-with-workers.html
fast/ruby/rubyDOM-remove-rt-block-1.html
webgl/1.0.2/conformance/context/context-release-upon-reload.html
Comment 15 Build Bot 2017-12-14 17:37:35 PST
Created attachment 329428 [details]
Archive of layout-test-results from ews115 for mac-elcapitan

The attached test failures were seen while running run-webkit-tests on the mac-debug-ews.
Bot: ews115  Port: mac-elcapitan  Platform: Mac OS X 10.11.6
Comment 16 Antti Koivisto 2017-12-15 00:45:16 PST
Created attachment 329469 [details]
patch
Comment 17 Build Bot 2017-12-15 01:16:17 PST
Comment on attachment 329469 [details]
patch

Attachment 329469 [details] did not pass mac-ews (mac):
Output: http://webkit-queues.webkit.org/results/5670982

Number of test failures exceeded the failure limit.
Comment 18 Build Bot 2017-12-15 01:16:18 PST
Created attachment 329472 [details]
Archive of layout-test-results from ews101 for mac-elcapitan

The attached test failures were seen while running run-webkit-tests on the mac-ews.
Bot: ews101  Port: mac-elcapitan  Platform: Mac OS X 10.11.6
Comment 19 Build Bot 2017-12-15 01:32:52 PST
Comment on attachment 329469 [details]
patch

Attachment 329469 [details] did not pass mac-debug-ews (mac):
Output: http://webkit-queues.webkit.org/results/5671011

Number of test failures exceeded the failure limit.
Comment 20 Build Bot 2017-12-15 01:32:53 PST
Created attachment 329473 [details]
Archive of layout-test-results from ews116 for mac-elcapitan

The attached test failures were seen while running run-webkit-tests on the mac-debug-ews.
Bot: ews116  Port: mac-elcapitan  Platform: Mac OS X 10.11.6
Comment 21 Build Bot 2017-12-15 01:35:05 PST
Comment on attachment 329469 [details]
patch

Attachment 329469 [details] did not pass mac-wk2-ews (mac-wk2):
Output: http://webkit-queues.webkit.org/results/5671095

Number of test failures exceeded the failure limit.
Comment 22 Build Bot 2017-12-15 01:35:07 PST
Created attachment 329474 [details]
Archive of layout-test-results from ews106 for mac-elcapitan-wk2

The attached test failures were seen while running run-webkit-tests on the mac-wk2-ews.
Bot: ews106  Port: mac-elcapitan-wk2  Platform: Mac OS X 10.11.6
Comment 23 Build Bot 2017-12-15 01:51:01 PST
Comment on attachment 329469 [details]
patch

Attachment 329469 [details] did not pass ios-sim-ews (ios-simulator-wk2):
Output: http://webkit-queues.webkit.org/results/5671204

Number of test failures exceeded the failure limit.
Comment 24 Build Bot 2017-12-15 01:51:03 PST
Created attachment 329478 [details]
Archive of layout-test-results from ews123 for ios-simulator-wk2

The attached test failures were seen while running run-webkit-tests on the ios-sim-ews.
Bot: ews123  Port: ios-simulator-wk2  Platform: Mac OS X 10.12.6
Comment 25 Antti Koivisto 2017-12-15 01:55:39 PST
Created attachment 329479 [details]
patch
Comment 26 Build Bot 2017-12-15 03:27:24 PST
Comment on attachment 329479 [details]
patch

Attachment 329479 [details] did not pass mac-debug-ews (mac):
Output: http://webkit-queues.webkit.org/results/5671887

New failing tests:
webgl/1.0.2/conformance/context/context-release-with-workers.html
Comment 27 Build Bot 2017-12-15 03:27:26 PST
Created attachment 329483 [details]
Archive of layout-test-results from ews113 for mac-elcapitan

The attached test failures were seen while running run-webkit-tests on the mac-debug-ews.
Bot: ews113  Port: mac-elcapitan  Platform: Mac OS X 10.11.6
Comment 28 WebKit Commit Bot 2017-12-15 04:35:07 PST
Comment on attachment 329479 [details]
patch

Clearing flags on attachment: 329479

Committed r225969: <https://trac.webkit.org/changeset/225969>
Comment 29 WebKit Commit Bot 2017-12-15 04:35:09 PST
All reviewed patches have been landed.  Closing bug.
Comment 30 Radar WebKit Bug Importer 2017-12-15 04:38:16 PST
<rdar://problem/36072040>
Comment 31 Ryan Haddad 2017-12-15 18:05:49 PST
Reverted r225969 for reason:

This change introduced LayoutTest crashes.

Committed r225994: <https://trac.webkit.org/changeset/225994>
Comment 32 Ryan Haddad 2017-12-15 18:06:13 PST
(In reply to Ryan Haddad from comment #31)
> Reverted r225969 for reason:
> 
> This change introduced LayoutTest crashes.
> 
> Committed r225994: <https://trac.webkit.org/changeset/225994>
Details and report steps in https://bugs.webkit.org/show_bug.cgi?id=180896
Comment 33 Ryan Haddad 2017-12-15 18:06:25 PST
*** Bug 180896 has been marked as a duplicate of this bug. ***
Comment 34 zalan 2017-12-15 18:32:20 PST
oh nooo!!!
Comment 35 Antti Koivisto 2017-12-16 04:56:50 PST
Created attachment 329572 [details]
patch
Comment 36 WebKit Commit Bot 2017-12-16 11:07:59 PST
Comment on attachment 329572 [details]
patch

Clearing flags on attachment: 329572

Committed r226007: <https://trac.webkit.org/changeset/226007>
Comment 37 WebKit Commit Bot 2017-12-16 11:08:01 PST
All reviewed patches have been landed.  Closing bug.