Bug 180718 - Add CanvasRenderingContext2DBase class and OffscreenCanvasRenderingContext2D
Summary: Add CanvasRenderingContext2DBase class and OffscreenCanvasRenderingContext2D
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Canvas (show other bugs)
Version: WebKit Nightly Build
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Dean Jackson
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2017-12-12 14:07 PST by Dean Jackson
Modified: 2017-12-12 16:35 PST (History)
9 users (show)

See Also:


Attachments
Patch (207.85 KB, patch)
2017-12-12 14:17 PST, Dean Jackson
no flags Details | Formatted Diff | Diff
Patch (208.42 KB, patch)
2017-12-12 15:12 PST, Dean Jackson
sam: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Dean Jackson 2017-12-12 14:07:20 PST
Add CanvasRenderingContext2DBase class and OffscreenCanvasRenderingContext2D
Comment 1 Radar WebKit Bug Importer 2017-12-12 14:07:58 PST
<rdar://problem/36004015>
Comment 2 Dean Jackson 2017-12-12 14:17:35 PST
Created attachment 329154 [details]
Patch
Comment 3 EWS Watchlist 2017-12-12 14:21:06 PST
Attachment 329154 [details] did not pass style-queue:


ERROR: Source/WebCore/html/canvas/CanvasRenderingContext2DBase.h:134:  The parameter name "a" adds no information, so it should be removed.  [readability/parameter_name] [5]
ERROR: Source/WebCore/html/canvas/CanvasRenderingContext2DBase.h:135:  The parameter name "a" adds no information, so it should be removed.  [readability/parameter_name] [5]
ERROR: Source/WebCore/html/canvas/CanvasRenderingContext2DBase.h:139:  The parameter name "a" adds no information, so it should be removed.  [readability/parameter_name] [5]
ERROR: Source/WebCore/html/canvas/CanvasRenderingContext2DBase.h:140:  The parameter name "a" adds no information, so it should be removed.  [readability/parameter_name] [5]
ERROR: Source/WebCore/html/canvas/CanvasRenderingContext2DBase.h:164:  The parameter name "a" adds no information, so it should be removed.  [readability/parameter_name] [5]
ERROR: Source/WebCore/html/canvas/CanvasRenderingContext2DBase.h:165:  The parameter name "a" adds no information, so it should be removed.  [readability/parameter_name] [5]
Total errors found: 6 in 17 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 4 Dean Jackson 2017-12-12 15:12:10 PST
Created attachment 329165 [details]
Patch
Comment 5 EWS Watchlist 2017-12-12 15:15:15 PST
Attachment 329165 [details] did not pass style-queue:


ERROR: Source/WebCore/html/canvas/CanvasRenderingContext2DBase.h:134:  The parameter name "a" adds no information, so it should be removed.  [readability/parameter_name] [5]
ERROR: Source/WebCore/html/canvas/CanvasRenderingContext2DBase.h:135:  The parameter name "a" adds no information, so it should be removed.  [readability/parameter_name] [5]
ERROR: Source/WebCore/html/canvas/CanvasRenderingContext2DBase.h:139:  The parameter name "a" adds no information, so it should be removed.  [readability/parameter_name] [5]
ERROR: Source/WebCore/html/canvas/CanvasRenderingContext2DBase.h:140:  The parameter name "a" adds no information, so it should be removed.  [readability/parameter_name] [5]
ERROR: Source/WebCore/html/canvas/CanvasRenderingContext2DBase.h:164:  The parameter name "a" adds no information, so it should be removed.  [readability/parameter_name] [5]
ERROR: Source/WebCore/html/canvas/CanvasRenderingContext2DBase.h:165:  The parameter name "a" adds no information, so it should be removed.  [readability/parameter_name] [5]
Total errors found: 6 in 18 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 6 Sam Weinig 2017-12-12 15:32:21 PST
Comment on attachment 329165 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=329165&action=review

> Source/WebCore/html/canvas/OffscreenCanvasRenderingContext2D.idl:35
> +//    void commit();
> +    readonly attribute OffscreenCanvas canvas;

This comment should be next to the type, match the ones below.
Comment 7 Dean Jackson 2017-12-12 16:35:27 PST
Committed r225816: <https://trac.webkit.org/changeset/225816>